Bronco Forum - Full Size Ford Bronco Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
66 Posts
Discussion Starter #1
:whiteflag I have an 88 351 running dual exaust no 02 sensor and its running ritch, now ive heard tales that you can lean it out by jumping out the sensor plug, is this true/ reccomended??? has a three wire plug dont know what to do other than replace the exaust system
 

·
Ex Navy Nuke
Joined
·
5,421 Posts
Get an O2 sensor bung and have it welded in your current exhaust system so you can install an O2 sensor. Much cheaper than a whole new exhaust system. Have you pulled codes? If not you need to just to make sure that's the cause of your problem. Although I suspect it is you still need to make sure.
 

·
Registered
Joined
·
66 Posts
Discussion Starter #3
im sorry i forgot to mention its running duals from the stock manifolds
dont ask me why, the guy i bought it from did it :wacko :wtf is there any way to run two o2 sensors, or would i have to re program
 

·
Ex Navy Nuke
Joined
·
5,421 Posts
No, you only need one anyway. Have the bung welded in on the pass side exhaust pipe as close to the manifold as possible and you'll be fine. My wife's F-150 has dual exh with stock manifolds and 1 O2 sensor on the pass side exhaust pipe and it works fine. Many others on here have done the same thing.
 

·
Registered
Joined
·
76 Posts
im in the same situation, i stripped out my old 02 sensor today trying to get it out.. 7/8 box end fit well but still stripped it.. must have been metric.. but im picking up a bung tommorow... the 02 sensor right now is in the y-pipe... does it matter where i put the new one?
 
1 - 6 of 6 Posts
Top