Bronco Forum - Full Size Ford Bronco Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Need some help. My 95 XLT OD light is flashing and speedometer and miledge is all off. Shifting very rough as well. I did some research on here and some people said to change the #18 fuse. I pulled it out, and sure enough it was blown. Went to put in a new one and it blew immediately. Any suggestions on where to turn next?
 

·
Registered
Joined
·
1,329 Posts
you need to go to the junction here and disconnect system by system to find your short. (that one on the right with the 7 wires out of it)
171401
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
you need to go to the junction here and disconnect system by system to find your short. (that one on the right with the 7 wires out of it)
View attachment 171401
Thank you!
you need to go to the junction here and disconnect system by system to find your short. (that one on the right with the 7 wires out of it)
View attachment 171401
I really appreciate the help! I’m a newbie with this Bronco. Just got it a few weeks ago. Can you tell me where to go to disconnect these systems?
 

·
Registered
Joined
·
1,329 Posts
Ah, now that I can't, all my stuff is older. But you could start by checking at the fuse box, they could all be connected right there. But there could as well be a junction box or terminal mounted on the firewall or fender, or up under the dash. I know on some of the factory split wires they'll have one wire into a plug and the plug functions as a junction, sending power out on 2 or more wires.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
I found the culprit. It was the airbag control module. I unplugged it and everything is working again. Thanks for your help!
 
1 - 5 of 5 Posts
Top