Bronco Forum - Full Size Ford Bronco Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
77 Posts
Discussion Starter #1
:banghead ok, so i changed the oil pressure sending unit to a mechanical one. started vehicle and it read 50psi.....vehicle cold. let engine warm up and gauge read below 25psi. it was on the line in between 0 and 25. looked at the oil line and it had gaps of oil in the line. it wasn't a constant flow. checked for kinks in line.....found none. drove vehicle home going bout 70-75mph.....needle still at same mark.

ok, so now I am thinking I have an oil pump problem.....would or can an oil leak cause this problem? (not the right pressure) I know the oil is leaking around oil pan...bad seal...prolly dryrotted....etc. leaks very minimal....

hmmm, so many choices so little time.....please don't blow engine!!!
 

·
green ones make me horny
Joined
·
11,154 Posts
Cocoyam said:
:banghead ok, so i changed the oil pressure sending unit to a mechanical one. started vehicle and it read 50psi.....vehicle cold. let engine warm up and gauge read below 25psi. it was on the line in between 0 and 25. looked at the oil line and it had gaps of oil in the line. it wasn't a constant flow. checked for kinks in line.....found none. drove vehicle home going bout 70-75mph.....needle still at same mark.

ok, so now I am thinking I have an oil pump problem.....would or can an oil leak cause this problem? (not the right pressure) I know the oil is leaking around oil pan...bad seal...prolly dryrotted....etc. leaks very minimal....

hmmm, so many choices so little time.....please don't blow engine!!!

Do you have enough oil in the truck? Does the oil pressure guage go up when you hit the gas? 50 at start up and 20 at warm idle isnt that bad doesnt your truck have like 200k plus on the odometer? might be time for a new oil pump as well. if you are going to do that run some cleaner through it like seafoam and let it clean it out a little.

ken
 

·
Registered
Joined
·
77 Posts
Discussion Starter #3
imlikeojnow said:
Do you have enough oil in the truck? Does the oil pressure guage go up when you hit the gas? 50 at start up and 20 at warm idle isnt that bad doesnt your truck have like 200k plus on the odometer? might be time for a new oil pump as well. if you are going to do that run some cleaner through it like seafoam and let it clean it out a little.

ken
yea, made sure the oil was correct, it was. yea, she does have 200k. you say run cleaner thru it, seafoam?? is that something you put in and still drive the vehicle?
I am soooooo regretting doing this erl pump!! maybe I should just put a different motor in it. oh boy...here goes my vacation money!!! lol
 

·
green ones make me horny
Joined
·
11,154 Posts
Cocoyam said:
yea, made sure the oil was correct, it was. yea, she does have 200k. you say run cleaner thru it, seafoam?? is that something you put in and still drive the vehicle?
I am soooooo regretting doing this erl pump!! maybe I should just put a different motor in it. oh boy...here goes my vacation money!!! lol

Well if you want to put a new motor in it go for it but I would get the one you got compression tested first. The oil pump really isnt that bad of a job. try the rear main seal...hahahaha

seriously though when you hit the gas does the oil pressure go up?
 

·
Registered
Joined
·
77 Posts
Discussion Starter #5
no, it doesn't. it stays the same. think I might just do the oil pump. motor sounds strong. any problems you think that can happen? I know the dealer was saying something about the bearings.....

anyone in the woodbridge or fredericksburg, va area want to lend a hand. think I might do it this Saturday.....
 

·
green ones make me horny
Joined
·
11,154 Posts
if the engine is quiet i wouldnt worry about the bearings just yet. you can check them when you get the pan off, but that is the same thing they rtold me and it wasnt them. i took my olkd pump off at 186000 miles and it was stuck half open. there is a check valve inside the pump and that srping wears out so you could just buy an new oil pump throw it on there ans see what happens then. it is 25 bucks and a day of your time.

also seafoam is something you can add to your crank case about week before you do this and it will clean shit out.

ken
 

·
green ones make me horny
Joined
·
11,154 Posts
there was someone in your old post about this same thing that was willing to help you out. look them up
 

·
Registered
Joined
·
77 Posts
Discussion Starter #8
thanks for the help ken. will put that cleaner in tomorrow. I ordered the oil pump last week from ford, just waiting for it to come in. will do it on Saturday.

once again thanks for the help....time for me to hit the sack...work in the mornin!! Late!!
 

·
green ones make me horny
Joined
·
11,154 Posts
actually put that seafoam in it about 100 miles before the oil/ pump change. also when you change the pump get the screen and tube as well. dont forget about the dizzy rod also. this is one of the reasons i put a new motor in. mine was so sludged up that i got tired of pulling screens and cleaning them
 
1 - 12 of 12 Posts
Top