Bronco Forum - Full Size Ford Bronco Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
273 Posts
Discussion Starter #1
I searched and all of the threads were about low oil pressure.

Idle at start up: 70psi
Idle when warm: 20-25 psi
At 2500rpm / engine cold: 70 psi
At 2500 rpm / engine warmed up: 50-55psi
All measured with a mechanical gauge.

This is for my Bronco (spec's on the left). Is this considered normal?
 

·
green ones make me horny
Joined
·
11,135 Posts
Yes that is normal anything about 20 is good. How many miles are on it?
 

·
Registered
Joined
·
3,213 Posts
Thats perfectly normal..My new engine runs around in that area..
 

·
Registered
Joined
·
273 Posts
Discussion Starter #4
imlikeojnow said:
Yes that is normal anything about 20 is good. How many miles are on it?
The odometer says 893 miles. I believe the odometer has rolled over a couple of times. The engine is a Ford reman'd long block with about 10,000 miles. The oil pressure sending unit went bad and so I replaced it and put in a mechanical gauge. I just didn't know what was considered normal.
 

·
Registered
Joined
·
3,213 Posts
Your good to go!
 

·
green ones make me horny
Joined
·
11,135 Posts
slaga said:
The odometer says 893 miles. I believe the odometer has rolled over a couple of times. The engine is a Ford reman'd long block with about 10,000 miles. The oil pressure sending unit went bad and so I replaced it and put in a mechanical gauge. I just didn't know what was considered normal.

yup you are good man. that is normal
 

·
Registered
Joined
·
251 Posts
Yah, like what imlikeojnow, above 20 is pretty good. Some people on here won't even get any! So don't worry bout it
 

·
Registered
Joined
·
1,315 Posts
does any body no the specs its supoed to be? i looked on alldata but the computer at work is fubar..

o ya for an 86 351w carb
 

·
Premium Member
Joined
·
7,395 Posts
yep they are great compared to mine. I have about 50 at start up and when it warms up about 5 or so. if i rev it up it may go to 15 or 20 but thats about it. mine a '86 351W w/ 160K
Damn, I am surprised the idiont light doesn't come on below 6 psi.:shocked
 

·
Registered
Joined
·
1,299 Posts
Damn, I am surprised the idiont light doesn't come on below 6 psi.:shocked
Well i don't have the factory sender anymore i changed it for a mech one. but if i had the factory i bet it would be going off
 

·
Registered
Joined
·
25 Posts
yep they are great compared to mine. I have about 50 at start up and when it warms up about 5 or so. if i rev it up it may go to 15 or 20 but thats about it. mine a '86 351W w/ 160K


Is your truck daily driven with that low oil pressure? What type and weight oil are you running? Any noises from the bottom end yet?

-Scott
 

·
Registered
Joined
·
1,010 Posts
yep they are great compared to mine. I have about 50 at start up and when it warms up about 5 or so. if i rev it up it may go to 15 or 20 but thats about it. mine a '86 351W w/ 160K
Sounds like mine, my engine makes 9psi (warm) at idle and only 23psi (warm) at 70mph.
 

·
Registered
Joined
·
25 Posts
Sounds like mine, my engine makes 9psi (warm) at idle and only 23psi (warm) at 70mph.

Do you drive your truck daily? Any noises or problems from the low oil pressure? What oil type weight and quarts do you use? Thanks for the help!

-Scott
 

·
Registered
Joined
·
11,108 Posts
I've got an old International tractor at work, with IIRC a Detroit 6v92T, and it generates about 2psi at idle warm, and about 12 to 15 at WOT. And it's still kickin.

I don't totally believe all the things they say about numbers, but I agree that you should have at least 30-40 at 4k rpm, and at least 15 at cruise at a minimum.
 

·
Registered
Joined
·
1,862 Posts
My 1993 DD just clicked over 100,000 miles, and she runs better than a top. The oil pressure measured on both my shop gauge and later on my gauge pod with a AutoMeter Phantom series gauges exactly the same.....oh and also a Sun-Pro el cheepo gauge also measured the same.

At idle.....hot/warm its at 25-30 PSI
Under load on the highway at 70MPH/2000RPM I am at 50PSI.
 

·
Registered
Joined
·
1,010 Posts
Do you drive your truck daily? Any noises or problems from the low oil pressure? What oil type weight and quarts do you use? Thanks for the help!
Yes, it is driven at least 30 miles daily. I am using 5.5 quarts of 10W-30. No problems so far from the low oil pressure but I have noises all over the engine, although they were caused more by THIS than the low oil pressure (isn't helping though).
 

·
Registered
Joined
·
25 Posts
Anyone try any type of oil treatments and seen an improvement in the low oil pressures? Hpw about a specific oil or weight that you are getting better readings from?

-Scott
 
1 - 19 of 19 Posts
Top