Bronco Forum - Full Size Ford Bronco Forum banner
1 - 11 of 11 Posts

·
Stuck like a MoFo
Joined
·
3,450 Posts
if the spring is keeping the bypass from opening yes. Why? Did a oil filter blow up? Could have been a shotty filter.

Constant gaskets blowing? checked the PCV system lately


I have a Hi pressure pump on a poncho motor and until warm, above a 1000 rpm pegs a 100lb psi gauge. Never had it cause any leaks anywhere
 

·
green ones make me horny
Joined
·
11,148 Posts
NDIXIE said:
Can a oil pump put out to much pressure?

yes there is a check valve in the pump that will cause it to do that. that is what blew out my rear main seal and stuff.
 

·
Registered
Joined
·
946 Posts
Discussion Starter · #4 ·
yeah, I have replaced rear main seal. I replaced it while I installed a new torque converter. I rebuilt the engine and of course put a new one in, the one I relaced had only been in for about 4 months. This one has been in for a year. I has been leaking for awhile now. Not driping on the ground but but oil on the oil pan, and bell housing. I just don't think that a main seal should go out that soon.:shocked
 

·
green ones make me horny
Joined
·
11,148 Posts
I dont think so either. What kind of seal did you use? i got the expensive one on mine cause i didnt want to take a chance at it messing up on me
 

·
Satyr of the Midwest
Joined
·
17,747 Posts
Mebbe you have wear and/or scoring on the rear main seal journal?
 

·
green ones make me horny
Joined
·
11,148 Posts
SigEpBlue said:
Mebbe you have wear and/or scoring on the rear main seal journal?

thats what i was thinking but he said he had the engine rebuilt a year ago. thats why i didnt say anything.

on the other hand if he did it himself and he didnt sned the crank out to get polished on the other hand that is what could be wearing the rear main down.

ken
 

·
green ones make me horny
Joined
·
11,148 Posts
SigEpBlue said:
Mebbe you have wear and/or scoring on the rear main seal journal?

thats what i was thinking but he said he had the engine rebuilt a year ago. thats why i didnt say anything.

on the other hand if he did it himself and he didnt sned the crank out to get polished on the other hand that is what could be wearing the rear main down.

ken
 

·
green ones make me horny
Joined
·
11,148 Posts
NDIXIE said:
yes the crank was polished

kind of figured that i dont know many people that would rebuild the engine and not get the crank taken care of
 

·
Stuck like a MoFo
Joined
·
3,450 Posts
the motor didn't heppen to get too hot? or possibly stretch/ripped the seal when mounting the tranny?

Mine somehow overheated i assume as the complete seal was loose in the block
 
1 - 11 of 11 Posts
Top