Bronco Forum - Full Size Ford Bronco Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
i just bought my bronco saturday at an auction... and soon after found this site. it's my first bronco, and for that my first ford. it's a white '93 custom with a 5.0L & AOD. it was used in fleet service but definitely does not look to be abused... in fact, whoever had it last took care of it & that's why i bought it.
my primary use for my bronco is going to be as a tow rig for a small enclosed trailer(6x12) and as a secondary driver around town, but it will also be used for some occasional mild off-road use. i will be setting it up for that and will have plenty of tech questions to ask in the near future.
 

·
Living in Obscurity
Joined
·
1,928 Posts
Welcome, glad to have you aboard!
 

·
Offical FSB Map Maker
Joined
·
3,033 Posts
congrats on your new purchase! There are plenty of knowledgeable folks around here that may know a few things about dem broncos:toothless :toothless

Welcome to FSB
Vote each day for Top4X4SITE, just click at the top of the page and once a month for FOTM!
 

·
Registered
Joined
·
529 Posts
Gotta love newbies....

Welcome :beer
 

·
Charlie don't surf..
'92 Ford Bronco XLT
Joined
·
16,082 Posts
Glad to have you on board..Now let's see some pics...:beer :beer :beer
 

·
hates EVERYTHING!
Joined
·
11,451 Posts
Congrats on the new Bronco, I bet it turns out to be more than you planned...there a lil adictive....:toothless

A few things to know:
1. Make sure to vote for FOTM each month by going to the FOTM thread and picking your fav. nominee! (10 new nominees each month, and someday it could be you!)
2. Be sure to vote for this site at TOP4x4 by clicking the link at the top of the page. (It brings us in alot of new traffic!)
3. Post up some pics of your rig! (click here-->click me, click me!! to find out how!)
4. Add your rig's specs (or a pic) to your sig line. (It comes in handy when asking questions for people to know what kinda rig thier helping you with!)
5. Before asking a handfull of questions please try the search button at the top right hand corner of the page.
It looks like this:
This site has been around long enough that ALOT of topics have already been discussed and now all you gotta do is read.

Welcome aboard, make your self at home!!!:thumbup
 

·
College User
Joined
·
2,026 Posts
Welcome :beer
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #17 ·
thanks for the input everyone.
been doing some searching on subjects that are concerns, and have been learning more about my rig.
the transmission is a E4OD, not an AOD (not sure which is the better unit to have)... i bought a trans filter & gasket today to do a fluid change when i get the time.
the check engine light has been on, so i bought a trouble code reader & it says the O2 sensor is reporting a rich condition and that the EGR valve sensor voltage is high( the valve isn't closing).... those parts look like they have been replaced recently, so i'm not sure what's up, maybe they just look clean.
 

·
College User
Joined
·
2,026 Posts
Do you have the O2 sensor, and is it connected. I have no O2 sensor so the light is on with two others all of the time.
 
1 - 20 of 22 Posts
Top