Bronco Forum - Full Size Ford Bronco Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter · #1 ·
Hello all. My speedometer reads zero. I pulled the cable with the sensor out of the TC. I got a C-6 tranny... Anyways, the plastic gear at the end of the speedo sensor has a play on it. I put some marine tex inside the gear and put it back in place. Im getting a reading on the speedometer. I like to order just the plastic gear at the end of the sensor. Anyone knows where I can order that part? I went to the Ford dealership here and they have the sensor without the plastic gear so its not help to me. Thanks a lot.
 

·
Registered
Joined
·
1,862 Posts
Did you check LMC truck or Jeff's Bronco Graveyard???
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #3 ·
Guys, I still can't find the speedo gear. I need a 17 teeth. The ones inside the transfer case are good to go. Just need the one that goes on the sensor/cable.

Seems like everyone sells the sensor without the gears. Any ideas on where else to check????? Also, will this issue affect how the transmission shifts on a C-6?
 

·
Registered
Joined
·
213 Posts
I ran into this on my truck as well--I just went to the dealer and asked for speedo GEARS (not sensors--that may be causing the confusion)
There are 2 different styles--on one, the gear teeth are about one inch long, and there is a 1/2 inch "nipple" sticking out; the other style has teeth about one and 1/2 inches long, and a very small "nipple" on the end.
I didn't know which style I needed, so I just ordered both--cost me around $12 total
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top