Bronco Forum - Full Size Ford Bronco Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1
What is up with this thing????

 

·
Registered
Joined
·
73 Posts
Discussion Starter #3
I guess. I may pull it and put a console monitor up there and hook it into my dvd player.
 

·
Registered
Joined
·
142 Posts
iv got a 96 and i does the same thing just on start up than it just shuts off i looked at the diplay screen and has a dark spot like it hot heated up and i would also like to fix it
 

·
U jelly of my
Joined
·
3,204 Posts
you set it to Japanese, see, it says "yen"... meaning, its gonna take some serious yen to have the dealer put it back to engrish
 

·
Registered
Joined
·
73 Posts
Discussion Starter #6
That, or I can just learn Japanese
 

·
Registered
Joined
·
7,916 Posts
The printed circuit likes to burn out. The explorer consoles use the same circuit and its a direct swap.

If you are going to pull it and want to unload it, let me know, I'd be interested in buying it off of you.

I have one in my 96 but I want one for parts.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #9
Will check a few yards to see if they have them. Thx
 

·
Registered
Joined
·
7,916 Posts
Will check a few yards to see if they have them. Thx
Just make sure to physically pull the board out and look for a burned spot. I've made the mistake of buying a few burned ones out of the yard w/o looking.:doh0715:
 

·
Registered
Joined
·
142 Posts
if anyone find one out of an explorer let me know. cause iv tried the whole state of florida it seems like ,and dealership dont make it
 

·
Registered
Joined
·
268 Posts
Just pulled one off a 96 from the wrecking yard....nice headliner too...

Where does the long harness plug in? Does anyone have a schematic showing where it goes?
 

·
Registered
Joined
·
331 Posts
x2... also can an overhead console be mounted in a 1990? I havent had the headliner out so I dont know if the mounts are there on mine or not.... I sure would like one even though i know it will burn up quick on a black vehicle...
 

·
Registered
Joined
·
6 Posts
I have a 1996 Bronco and mine would flash that didn't make since and I was lucky enough to find another one for fifty bucks at the dealer ship they wanted $400.
try holding in the mode button for 10 sec and see if it will give you a different reading. sometime they have to be calerbrated which the manual will guide you through
it. I had a burnt spot on both display panels and that had nothing to do with it working or not. Good luck and watch out for the tabs
that hold it up they are
easly broken if they are thighten to much.
 
1 - 17 of 17 Posts
Top