Bronco Forum - Full Size Ford Bronco Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I put the fitech 400hp fuel injection system on my 94 with an 89 351w last year and now have a 432 mA draw with the key off, is anyone familiar with the efi system or had a similar problem because this is kicking my a**
 

·
Registered
Joined
·
4,970 Posts
The modules that draw power (when everything is shut off) are the PCM, the RKE module, the the anti-theft module, and the radio (keep alive to keep your presets). Another thing that is sometimes overlooked is the light inside of the hood, but I seem to remember when I was looking for a parasitic load the underhood light was an amp or so.
The parasitic load I measured on my '94 (no Fitech of course) was 70ma. I compared that to my '96, and the '96 was 63ma.
As you know how to measure the parasitic load (and can read a multimeter apparently), I would suggest that first you pull the plug on any modules added with the Fitech installation. That way you can narrow it down to something that was added or something that is in your original wiring. Then the binary search of pulling fuses and observing whether the load drops.
Good Luck.
I have a lot (but not all) of the '94 EVTM on my Supermotors pages. It starts here:
https://www.supermotors.net/registry/media/1129423
 

·
Registered
Joined
·
1,078 Posts
fitech should only draw for its ecm memory
 

·
Registered
Joined
·
115 Posts
Unplug the handheld screen. It kills the battery. Done it a few times with the FiTech
 
1 - 5 of 5 Posts
Top