Bronco Forum - Full Size Ford Bronco Forum banner

1 - 20 of 68 Posts

·
Engineer
Joined
·
13,163 Posts
Just post the pics here directly
 

·
Registered
Joined
·
453 Posts
Discussion Starter #3
i cant figure it out i think my comp is jacked. it keeps sayn upload failed.
 

·
Registered
Joined
·
453 Posts
Discussion Starter #6
i just tried it and it worked so idn. im guna look at that stickey. in a min
 

·
Registered
Joined
·
453 Posts
Discussion Starter #8
ha yea it did. still does with only 35s. need 40s or 44s. hopefully soon.
 

·
Lick my balls
Joined
·
13,023 Posts
Yeah, you need bigger tires to fill up those wheel wells.




I hope you have more than just those few tacks holding that 1/2" plate in place
 

·
Registered
Joined
·
453 Posts
Discussion Starter #10
o yea most definetly that was about a month before it was done. i have not broken anything as of yet. my dad is a welder, fabricator by trade so i didnt expect to break any. and i did pull the pins outa the springs and put bolts in there, a buddy of myne 4got, he got excited and had a cheby and drove to school with pins instead of bolt in the leaf springs.
 

·
Registered
Joined
·
1,024 Posts
id suggest plating over the cruple zones on the side. And im going to agree with Walt, I hope that those little tack welds arent the only thing holding that plate on the bottom of the frame rail. other then that, go buy some boggers!
 

·
Registered
Joined
·
453 Posts
Discussion Starter #13
the outside is plated with half inch plate and its reinforced farther back. like i said no problems yet, nothing bent or anything like that. 80 down the freeway is stabe. had it back in a field bouncin around a few times and its still all together, if i put a 460 in ill do some more reenforcing. if i had the money for some boggers i would do that to.
 

·
Registered
Joined
·
453 Posts
Discussion Starter #14
the toyos are my dads tires i had those on for a while instead of the 31s and then i got myown 35s. yay me. i get em cheap through a buddy and i have a welded diff so i eat em fast.
 

·
Registered
Joined
·
453 Posts
Discussion Starter #16
there off of a chevy dump truck. a 96 or so my uncles a mechanic for a land scaping company and there scrappe3d the truck i think they were 2 or 5 ton i dont remember what he said. they dont ride bad eather
 

·
Former owner of Shadofax
Joined
·
17,025 Posts
On your second page, I'm not an expert on the leafs, but it looks like your shackle angle is all wrong. Also, what's the deal with mounting your shocks into the short TTB towers? Looks like you only have perhaps 3" of shock uptravel.... maybe you won't need much up travel if you are using 2 or 5ton dump truck springs.
 

·
Registered
Joined
·
453 Posts
Discussion Starter #18
the shackles were suposta be shortened. but i wanted it high and i had wanted to go with a set of actual lift springs in the front. so yea the angle never was really messed with. and we are in the process of making shock towers but then it was a quick fix just so i can drive it since its my dd. and before i do much wheeling the rear block and the shocks are going to be redone.
 

·
Registered
Joined
·
453 Posts
Discussion Starter #19
On your second page, I'm not an expert on the leafs, but it looks like your shackle angle is all wrong. Also, what's the deal with mounting your shocks into the short TTB towers? Looks like you only have perhaps 3" of shock uptravel.... maybe you won't need much up travel if you are using 2 or 5ton dump truck springs.
also there was debate on if i was going to use a coil or keep the leafs. still havent fully decided. it flexs nice and rides nice so im not shore if i wana go through changing stuff.
 

·
Administrator
Joined
·
22,840 Posts
1. you need a better crossmember between those front spring mounts
2. you shackle angle on the back of the front springs is jacked...fix it
3. as many leaves you have in the front you are going to get no flex what so ever.
 
1 - 20 of 68 Posts
Top