Bronco Forum - Full Size Ford Bronco Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi everyone I just got my ford bronco is a 1988 bronco xlt it has a v8 302 in it. The timing was moved forward when I got it and it has decent power but when i move the timing to where it should be i have to floor it just to get to 15mph any ideas weberi should start with this issue?
 

·
Registered
Joined
·
4 Posts
hey...before changing out spark and fuel components randomly,pull your codes. check babalouey thread in newbie zone for howto.....also what caused you to move timing? and what was your procedure?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Tooblueeyes i didn't move the timing forward the previous owner did thati have been trying to research it for awhile sincei know it could be multiple things
 

·
Registered
Joined
·
4 Posts
my bad,you did say it straight away...anywho i am a newbie (3 years since i bought my 88 bronco) i joined this Forum when i had my first of many issues... didnt know jack about engines, repair etc...,im 55..point is i refer to the Baba Looey's Favorite FSB Links...in the newbie tech flame free zone (lots and lots of tech links... every time it guides me thoroughly and i learn by doing and now nothing is intimidating to me at all. start there post your results and question...take the time, its worth it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
got the timing right or as close as i can but still feels like it doesnt have the power a v8 should have but i have never owned a v8 so im not sure. i think my ignition module is bad i know it can cause the egine to shut down since that has happened twice now could it also cause a power issue?
 

·
Registered
Joined
·
129 Posts
Pull codes to start with but several things can cause what you are seeing. One could just be a worn out motor, have you done a compression check on it?
Pull codes, get a vacuum gauge on it, should have ~ 17 at idle. Then get a a fuel pressure gauge on the fuel rail.
My 88 was set up just like that by the PO, the timing was way advanced and when it was set back to 10 degrees (SPOUT removed) it had no power. Now it also had a worn out engine and other issues. When we put a new engine in it it still had the same problem, it turned out to be that the PO had installed incorrect fuel injectors.

When you floor it does not just not rev up and go or does it backfire thru the intake or any other symptoms. Does it feel like it is being held back like the brakes dragging?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
Took it in to get it smogged and the timing was off and the intake manifold gasket was shot runs like a champ now
 
1 - 9 of 9 Posts
Top