Bronco Forum - Full Size Ford Bronco Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
I posted this over to the General Repair & Tech Help forum.. since seems it belongs there.

just had, K&N intake, JBA headers, Hi-Flow Catalytic converter, High flow muffler, all about 2 3/4 pipes I think. Anyway the whole job was about $2,000.

Was that way too much to pay for? I had it done at off road warehouse.

Not a duel , single pipe, was told other was going to be too much.

This is my impressions so far. I can't really tell the difference in power... The low end torque seems reduced.

My truck is 1993 Bronco with 5.8 liter V8. This is my third Bronco but I am new to this business of customizing. Also after the work now i have lots of backfiring.

Thanks much,
 

·
Registered
Joined
·
787 Posts
Stand up, and check to see if there's any blood spots on your chair.

:twak ignorance=$$$ :twak
 

·
Living in Obscurity
Joined
·
1,928 Posts
ValkariaKid said:
Stand up, and check to see if there's any blood spots on your chair.

:twak ignorance=$$$ :twak
:stupid :stupid :stupid :stupid :stupid :stupid :stupid
 

·
OUT OF BUSINESS / M.I.A.
Joined
·
10,857 Posts
:lolup you got hosed!

Let me price out my exhaust:
Right Header: $210
Left Header: $300
Custom crossover: $140
Flowmaster 3 chamber muff $70
Custom 3" tailpipe: $115

Total: $835 for entire exhaust system

Pictures here: http://www.superford.org/registry/vehicles/detail.php?id=1501&s=8841#content

NOTE! I had to buy 2 sets of headers, my truck uses a Ford motorsport header on the right and a MAC on the left. Couldn't use 1 matching set, so my cost is higher from buying 4 headers :banghead

So, $2000 is prison sex! :duh
 

·
Registered
Joined
·
96 Posts
YOU PAID $2000 FOR THAT!!! I hate to say it but you got screwed. I hope they used lubricant before they screwed you up the a$$. That just seems like way to much for an exhaust system. When I had mine done I ordered Hedman Elite Hedders thru Summit for $260 and Hi-Flow cats for $50 each (they were on sale when I ordered them). I bought some cherry bombs at a local parts store I think I paid $20 each. Also stainless steel tips for $50. My dual exhaust cost me about $300 to have installed. So my exhaust system cost me about $750 not including tax and shipping. I have people tell me all the time that my exhaust sounds awesome.



http://fullsizebronco.superford.org/registry/vehicles/detail.php?id=3030
 

·
hates EVERYTHING!
Joined
·
11,451 Posts
Yup, they said it....you got phucked!:shrug The semi-good news is if it's back firing I'd carry it back and use that as the catilist to raise hell with 'em. I'm just that kinda guy, I guess...but I'd tell 'em "hey, this shit aint done right and for the price I paid it damn well better be perfect!!" Hell, I might would tell 'em to take the shit off and gimme me my money back...:shrug
 

·
Registered
Joined
·
150 Posts
do yourself a favor and print this whole thread and bring it to them and show management. Make them at least know they ****ed you, and that you know, and that you plan on telling others if they dont come up with some sort of rememdy.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #9
GET THIS !! THERES MORE

Ok this was installed though most posts seem to be saying just the cost of raw parts.

However...............................!

AFter the job they did.....I drove 400 miles on the wrong firing sequence also, with cylander #4 and #3 reverse I have been offered reimbursement for the diagnostic that was run to find this silly thing out. The manager was polite and din't fight about this reimbursement at least, which at least is something. Actually I have had good experiences with ORW before so this was a shock.

Here is reciept



my major concern right now is what kind of damage was done by having the firing sequence of (below) for 400 miles!! IE melting the brand new catalitic converter maybe? or beating the heck out of the engine in general.

1,4,7,2,6,5,3,8

verses the correct firing sequence of

1,3,7,2,6,5,4,8 which is what I understand (99%) sure it should be, anyway it finally ran right after I change it to this..

(unfortunely this is a run away cross post i posted this in the other thread too in repair)
 
1 - 11 of 11 Posts
Top