Bronco Forum - Full Size Ford Bronco Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Good Day board,
Breakline rusted lost all fluid breaks feel spongy. I was told bleed the RABS valve first I looked for it in the frame rails to no avail. Anyone know or heard of the preceedure?
Much Obliged Paul
95EB, 5.0
 
K

·
Guest
Joined
·
0 Posts
take it to brake specialists and get a quote, and just say you'll be back tomorrow.....



no show:thumbup
 

·
TTB Hater of course
Joined
·
3,100 Posts
HIGH_N_DRY said:
Good Day board,
Breakline rusted lost all fluid breaks feel spongy. I was told bleed the RABS valve first I looked for it in the frame rails to no avail. Anyone know or heard of the preceedure?
Much Obliged Paul
95EB, 5.0
Fireguy's pic is right. On your '95 you've got 4WABS, not just RABS. Good luck bleeding that valve, talk to Plug Ugly. Go ahead and bleed everything you can, it might work out. If not, it's probably off to the dealer for you.

I'll tell you MY solution: remove 4WABS valve, lay on concrete, smash with sledge until pancaked. Run new hard lines. Be happy with a brake system you can actually service at home now.
 

·
Offical FSB Map Maker
Joined
·
3,033 Posts
Hey HIGN_N_DRY my 95 did the same thing. From what the manual says, if I remember correctly you bleed that if you plan on taking it off or something. Anyways, I replaced the bad line and bleed all the brakes, didn't mess with any of that ABS stuff up front on the frame. Everything is back to normal and working good. I did this about a month or so ago.
 
1 - 5 of 5 Posts
Top