Bronco Forum - Full Size Ford Bronco Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
250 Posts
Discussion Starter #1
Through most of the summer and fall I've been fighting this problem. The truck backfires through the intake and feels like it's in the wrong gear. It also seems like when I give is gas to down shift it drops to neutral and revs way up before shifting into gear. It will start in second gear nearly all the time as well.

From reading other threads I think I've got a bad shifter lever sensor. I'm not getting any codes for that though. I did pull codes 2 days ago. Key on engine off: 111 system passes, no stored codes, and key on engine running 311 thermactor system isn't working.

I don't think the emissions system would make it drop to neutral and do wrong gears starts. I think the backfiring is because the transmission isn't shifting right and is loading up the engine too much. Any ideas and suggestions would be a huge help.
 

·
Registered
Joined
·
250 Posts
Discussion Starter #2
Anybody?
 

·
Premium Member
Joined
·
3,944 Posts
may be the shift sensor, mine seems to search for a gear, while cruising. it will sometimes start out in 2nd gear and wont down shift to passing gear when trying speed up unless you floor the pedal. i will look and see what i can find. keep us posted on the out come
 

·
I scrape on both sides
Joined
·
3,035 Posts
could be MLPS (be aware that part stores have it under NSS... just spent time with a parts guy for about 20 minutes trying to find it when he scrolled over the NSS and i had a head-bang-on-counter moment) or your TPS
 
1 - 4 of 4 Posts
Top