Bronco Forum - Full Size Ford Bronco Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I recently bought a 94 bronco 5.8 the speedometer is jumping big time and hard shifting when it gets warm. I have replaced the speed sensor cause that's the code given I do have 31s on it so do I have to reset the psom.?
 

·
Super Moderator
Joined
·
26,078 Posts
yo MN,
What is the Code #?

This problem could be caused by a # of things;
bad vehicle speed sensor (VSS) (also called ABS,, DSS sensor) sensor on 8.8 (rear differential)/ or
Connector/corroded wires inside connector;
or cruddy/damaged tone ring in the 8.8.
bad 4WABS Module - It is located below ws wiper fluid/coolant recovery tank. So, the connector can be corroded by leaking fluid
bad wiring/shorts /connectors from VSS at firewall, at 4WABS Module and /or at PSOM and then onto the PCMthe locations of the connectors along the path from VSS to 4WABS and up to Instr Cluster & PSOM are;

C404 VSS On rear axle sensor (A7) Terminals: 02

C205 LH rear of engine compartment, in safety wall (Fire Wall) Terminals: 24 In-Line

C202F & M LH rear of engine compartment, in safety wall (A8) Terminal: 7 In-Line

C119 LH front corner of engine compartment on 4WABS control module (E10),Terminals: 40

O/LB to:
C202F & M LH rear of engine compartment, in safety wall (A8) Terminal: 7 In-Line

C252 Programmable Speedometer/Odometer Module (PSOM), Behind top LH side of I/P, on PSOM (A7) Terminal: 12 Color: B at Pins 4

LG/Y to Splice S107 Engine control sensor harness, from C119 near T/O to G101 (G101 RH side of Radiator support); to PSOM Pin 5
C202 F and M
and spliced to Ground G100 (BK)
G100 & G104 (tied together in diagram) G100 @ LH front of engine compartment, on upper radiator support

G100 Serves Component:
Fuel Pump Module
Inertia Fuel Shutoff
Misfire Sensor
Misfire Sensor Shield
Output Shaft Speed (OSS) Sensor
Powertrain Control Module (PCM), 5.0L


From PSOM Pin 7 (GY/BK) to Splice S246 Main harness, near T/O to speed control amplifier to
C185 PK/O @ PCM 5.0L Powertrain Control Module (PCM) LH side of safety wall, on powertrain control module (PCM) (C10) Terminal: 104 Color: GY
C185, 5.8L Powertrain Control Module (PCM) LH side of safety wall, on powertrain control module (PCM) (C10) Terminal: 104 Color: GY

C185 @PCM to C202 F and M
Splice 216 to Ground G200, Instrument Cluster ground is inside passenger side kick panel

and on to C185 @ PCM PIN 58 (GY/BK) and from Pin 46 to MLPS (TR) Pin 2
Verify PCM & MLPS wiring & Pin numbers using following WIRING DIAGRAMs by Ford via Steve83
(my eyesight is fuzzy again)
http://www.supermotors.net/registry/media/95931_1

bad 4WABS Module - It is located below ws wiper fluid/coolant recovery tank. So, the connector can be corroded by leaking fluid
bad PSOM (Speedo)

I jumpered the Module out as Steve & Turbo Ghost describes below.

To bypass the 4WABS module @ it's harness's connector & feed the ABS signal directly to the PSOM,
Disconnect module (under coolant recovery /ws washer tank) & in connector, jumper LG/Bk to LG/Y, and R/Pk to O/LB..."
Source: by Steve83 (Steve, That dirty old truck) at http://www.supermotors.net/registry/media/170517_1
Pin numbers are shown in the wiring diagram

or with a pic of the connector and jumpers; Continuity Test Through 4WABS Module Connector in 93-96; "...jumper 14 (CKT 530, LG/Y) to 21 (CKT 519 (LG/BK) & 39 (CKT 491 (O/LB) to 22 (CKT 523, R/PK)...";

http://fullsizebronco.com/forum/showthread.php?t=201478&page=2
READ MORE @
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Sending codes 111,122,332,452, and 634. I have replaced the speed sensor and throttle body sensor. No change in how it shifts. No abs light on but thinking about changing the sensor for it under coolant/ washer tank. Any real advice would be appreciated.
 
1 - 4 of 4 Posts
Top