Bronco Forum - Full Size Ford Bronco Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
223 Posts
Discussion Starter · #1 ·
i have an 88 bronco with a 5.0 in it and lately it seems to be running rich

i drove home from college last friday (about 150 miles interstate) and it definetly smelled like it was running rich and when i got home my bumper was black with soot

none of my check engine lights are on so what should i look for?
 

·
Registered
Joined
·
164 Posts
i have an 88 bronco with a 5.0 in it and lately it seems to be running rich

i drove home from college last friday (about 150 miles interstate) and it definetly smelled like it was running rich and when i got home my bumper was black with soot

none of my check engine lights are on so what should i look for?
How long has it been since it had a tune up? Could it have a leaky injector? The list goes on

Just because the check engine light isn't on doesn't mean much. This isn't an OBD-II where the light comes on for every little issue.
 

·
Premium Member
Joined
·
9,995 Posts
I'm assuming you have a 302 EFI......................a lot depends on how many miles you have on the BKO motor ............I just swapped in a new 302 last month because it failed the Cali Smog test last year as a gross polluter due in fact to a dead # 2 cylinder, unspent fuel running rich but I'm not saying that's your problem entirely but maybe you need some head work.......

There are a ton of threads here to help you get better performance, "search" and pull codes from the PCM = power control module, the plugs are usually over on the right inside fender liner...www.fordfuelinjection has pictures of what they look like........"search" for how to pull codes etc.

Certainly a good tune-up would improve performance, check out "Sixlitre" ignition and timing upgrade, this would be ideal for you and relatively inexpensive.

Check your MAP -sensor = manifold absolute pressure
Clean you IAC -= idle air control, located on the side of the throttle body- check thread
Clean your Throttle Body, replace the gasket -check thread
Check your EGR sensor located on top of the EGR valve bolted to the FI plenum.....
Check your Timing and make sure it's correct.......
Check your Exhuast Header gaskests and bolts ......re-torque them

I would would check the FPR -fuel pressure regulator up on top and fuel injectors if you haven't looked at them in a while, you have to pull the Plenum off but a gasket is only $8-9.00 they just squirt fuel but if thery're clogged up.......if you go to www.fordfuelinjection.com it shows you how to clean and refurbish injectors and the kits are around $20.00 for screen and o rings etc.
I found Precision Automotive Injectors in FLA on EBay offering a very high quality set of remans that were cleaned, tested and shipped in 3 days for a total of $125.00 using google check out, correct injectors for my 86 and they worked out great....

This should keep you busy for a while, let us know what you find...................

Good Luck ~
 
1 - 6 of 6 Posts
Top