Bronco Forum - Full Size Ford Bronco Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hi
My 89 Bronc has a new crate engine (302) and is running rough as well as smells like gasoline bad. I replaced the MAP and O2 sensors no luck. It also backfires in 3rd gear. Any suggestions?
Art
Texas
 

·
Premium Member
If it is not a Bronco, it's just not worth driving.....
Joined
·
1,900 Posts
Look at your vacuum lines. See if anything is unplugged or leaking. Maybe even a gasket between parts. Raw air can really throw off sensors and they may be dumping too much gas in the intake.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
Thanx
But like I said, its a brand new crate engine. Pressure tested and guaranteed. I think its a bad sensor, but I dont know alot.
 

·
Registered
1986 Eddie Bauer 5.0EFI AOD Full length headers Y pipe into single 3" Magnaflow 3" factory exit
Joined
·
986 Posts
I just had posted about my similar debacle, which ended up being an air intake temp sensor. The best purchase you will ever make is a code reader at your local auto zone for $29.99, but only after i threw a bunch of parts at it first with zero success. Coil, fuel pressure regulator, coolant temp sensor... then I got a code reader, which lead me right to the AIT semsor problem & it actually got me to solve a few other problems I didn't know I had. Now my Bronco is running better than it ever has. Mine also has a new crate motor in it. I bought the truck from the guy that put the crate motor in & didn't put any new efi sensors in anything, which was all it needed.
169430

This was my debacle thread.
 

·
Registered
1986 Eddie Bauer 5.0EFI AOD Full length headers Y pipe into single 3" Magnaflow 3" factory exit
Joined
·
986 Posts
I had a new sensor in there, so I figured it was good. After enough throwing parts at it, I got my meter out & measured the resistance between the pins of that AIT sensor & it showed open so it was bad... I still had my old one, which metered still good, showing 0.34ohms @the 200k setting.
A little $12 part was all it was.
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top