Bronco Forum - Full Size Ford Bronco Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter #1
I decided upgrade my 1994 Bronco to Saginaw power steering (part 206244)and have had some bad luck....or something else. I bolted the first pump up no problem and was in the process of bleeding air from the line when the axel started smoking only after ~5 seconds with the Bronco running. It had fluid and suddenly drained out and I quickly shut off the engine but it was too late. I returned the unit and got another one. This time I left the return line off, cranked the engine for 1-2 second cycles to conform fluid was passing through the system without restriction. It came out of the return line with considerable pressure. I put the return line on with two clamps and started the Bronco, confirming the fluid level was maintained and discovered a significant leak between the reservior and the pump, on the bottom. This was at idle without moving the wheels at all. I am struggling with the idea of getting two bad units and wonder if there is another problem. My gearbox was running fine with the old system. My understanding is this gearbox is the same for 88-96 so it should not restrict the pressure in the Saginaw to blow out its seals given the 88 Bronco came with the Saginaw as a heavy duty upgrade. I would appreciate any suggestions on what to check as the "third" unit" will be here Saturday and I'm wondering if "the third times a charm" or my setup is causing so much back pressure in the Saginaw it blows it's own seal.


Thanks
 
1 - 2 of 2 Posts
Top