Bronco Forum - Full Size Ford Bronco Forum banner
1 - 7 of 7 Posts

·
Registered
‘95 xl, 5.8l, ZF S5-47, BW1356, SAS, D44(8lug), Sterling 10.25 (Detroit)
Joined
·
269 Posts
Discussion Starter · #1 ·
The old C2 pump uses type F fluid.
I doubt the Saginaw requires it, but I was wondering if I should purge the system of all that type F and put in regular PS fluid or just don't worry about it and bleed the pump and top it off with type F since I have a good amount of it sitting in my garage.

Thanks.

-matt
 

·
USAF Veteran
Joined
·
2,975 Posts
i just did a quick search and didn't see a specified fluid. maybe badass will chime in, since he sells used sags and did a great write up on the swap.
 

·
Master Bater
Joined
·
7,268 Posts
it shouldnt matter matt. I run synthetic ps fluid, but to be honest it smells and feels just like atf, so I am sure it was just a sales ploy to get dumbshits like me to pay a couple extra bucks. Run whatever you want, i am sure it would be fine. hell we have run gear oil to get off the trail before and it worked in the pump just fine.
 

·
Registered
Joined
·
13,891 Posts
i have run regular power steering fluid, trans fluid, and hydro/transmission john deere fluid in them, and they all seem to work fine.
the hydro/transmission john deere stuff i use in my zuk as it is much thicker for the fuill hydraulic ram. pumps the stuff just fine.
 

·
Registered
‘95 xl, 5.8l, ZF S5-47, BW1356, SAS, D44(8lug), Sterling 10.25 (Detroit)
Joined
·
269 Posts
Discussion Starter · #6 ·
Well, as a follow up, I used the type F fluid, the Sag whines louder than the old pump. I'll switch to regular PS fluid later.
The HP hose I bought was too big. I bent it and made it work but will be changing that out later too. The original hose looked OK but for $15, I figured why not just buy a new one? Oh well.

One note:
I bought a serp belt 2" longer than my original one based on advice. Well, I installed it and it was WAY too loose. I measured the pulley on the Sag and the pulley on my original pump and they were the exact same diameter. I re-installed my original belt and everything was fine.

Steering is remarkably improved. It's just stupid that these didn't come from the factory with these.

-m
 

·
Registered
Joined
·
13,891 Posts
glad to here that.
jafo, what year was your combo on your truck?
i know zilla's setup was way to small on his 95 to work.
it may whine for a tad tlll you get all the air out, but maybe you got a pump on its way out.
let me know if you need anything......
 
1 - 7 of 7 Posts
Top