Bronco Forum - Full Size Ford Bronco Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
117 Posts
Discussion Starter #1
Ok, my 1995 5.0 is acting up, maybe...It seems to have no get up and go compared to my old 5.0 pickup(too big of a difference for more weight to be the reason). it seems to be shifting too late to me as well. the drivetrain will get loud and not accelerate well, then quiet down and accelerate better, and then shift. its not a strange loud, just the normal sound the truck makes when accelerating, only substantially louder. I have checked transmission fluid and oil level, both are normal. also have tried KOEO codes, came back with 111, which is system pass. also when I am accelerating my overdrive seems to kick in way to early, is really loud(same loud as before) then quiets down and accelerates better(same as when not in OD). And it is worse when the A/C is on. My exhaust is loose between the muffler and cat and the trans recently got hot from towing and puked fluid from front seal(is now replaced and fine...). Any Ideas?
 

·
Registered
Joined
·
1,126 Posts
It could be a couple things. Is the rear end ratio the same in both trucks? Tire size similar? Other than that how heavy a load do you pull and when was the last time you serviced your tranny? You may have burnt the fluid (and maybe a couple compoments). I might suggest chaning the fluid and filters in the tranny.
 

·
Registered
Joined
·
117 Posts
Discussion Starter #3
gears are the same, tires are only 31"'s vs 30's on my other truck, pulled a boat(about 4500lbs) one time. checked the fluid when replacing the front seal (and replaced half of it) and it was fine, bright red, I guess I should check the filter too, was going to change that at 100,000 miles when I change all my other fluids, but I guess I could do it early...should probably change the fuel filter now too I guess...
 
1 - 3 of 3 Posts
Top