Bronco Forum - Full Size Ford Bronco Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Okay guys hopefully someone can help. Im a rather expirenced ford mechanic but with everything going on latly here at home i cant think strait. I have a 1988 F150 4x4 with a 351w and a C6 tranny. My truck has duel 18 gallon tanks. I filled up a few days ago and I got about 260 miles or so from one tank (you know turning 3,000 RPM's doing 70mph on the highway doesnt help). Anywho on monday I filled up again and made a round trip to Michigan and back. I notice on my way up there the needle falling faster then uasual. When i got home I had gone about 130 miles and the tank was nearly on E. I have no need to check the cat's cause the truck is running duel 2 1/2 inch stainless pipes with stainless flowmaster 40 mufflers. Exhaust is nearly new. The olny thing I can figure is my fuel filter is partially blocked, or dirty ass fuel injectors. I noticed now when I come off a stop sign and I hit it she is kind of slugish at first. Bogs then goes. Im going to pick up stuff for a tune up this weekend. Im wondering if its time to change the tranny filter as well???. I dont think its the tranny sliping as much as it is the truck bogging for a bit once i hit the gas hard. Other then that and the worn out steering box (go figure) the truck runs great and is reliable. I just want the better gas mileable back. Any ideas guys???? hope someone can help
 

·
Registered
Joined
·
11,108 Posts
Is the motor carb'd?

Do you have anything hanging up on your driveline? Brakes, u joints, bearings?

You should ditch the duals, a single 3" will outperform dual 2 1/2's.
 

·
aka: kemicalburns
Joined
·
7,874 Posts
if the truck is efi, where did the o2 sensor get placed? was an H pipe installed as well. have you pulled codes?

you might consider installing some 33's on there to help the rpms or start driving at 65 or less
 

·
Premium Member
Joined
·
5,103 Posts
:stupid (all of them!)...

If its me, I start by pulling codes. Make sure nothing comes up there....

Then, I would probly consider a tune up (if its due).... I would also make sure there was no irregular "drag" being caused by something on the truck like brakes etc....

Also, just a silly question... are you sure you dont have a check valve failing that is allowing gas to move from one tank to another?? It wouldnt explain the "bogging" (unless gas was not making it to the engine because it was going into the second tank) but would explain the quick use of gas in one tank....
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
the truck is a fuel injected 351w with a C6 3 speed automatic. New bearings, ball joints, U-joints, brakes and calapers a few months ago. Right now it olny has the side tank in it as the back one is pulled cause the sending unit went bad (go figure). A tune up is probobly needed yes. As for the 02 sensor its mounted I believe on the H-pipe. Right now its just running stock heigth with 31x10.50x15 Kelly AWR's on steel rims. Ill check the rear drums today and see if maybe the parking brake is stuck partially on since i used that a few days ago. Its just driving me bonkers you know. This weekend will be a tune up and such but any other sugjestions you guys have shoot um my way. also if you have any questions or need info just ask. Right now the Check engin and engin lights are one mainly because the hack wireing job that was done on the truck before. Before I got it, from brand new it was a shop truck. I have taken it to a local ford shop (I hate taking my stuff to shops) and they checked everything and said it was fine. The lights are on cause a few wires have been rewired so some things dont read right. Plus they have been on since I bought it and I have replaced about everything you can. Hope you guys can help
 

·
Registered
Joined
·
11,108 Posts
the truck is a fuel injected 351w with a C6 3 speed automatic. New bearings, ball joints, U-joints, brakes and calapers a few months ago. Right now it olny has the side tank in it as the back one is pulled cause the sending unit went bad (go figure). A tune up is probobly needed yes. As for the 02 sensor its mounted I believe on the H-pipe. Right now its just running stock heigth with 31x10.50x15 Kelly AWR's on steel rims. Ill check the rear drums today and see if maybe the parking brake is stuck partially on since i used that a few days ago. Its just driving me bonkers you know. This weekend will be a tune up and such but any other sugjestions you guys have shoot um my way. also if you have any questions or need info just ask. Right now the Check engin and engin lights are one mainly because the hack wireing job that was done on the truck before. Before I got it, from brand new it was a shop truck. I have taken it to a local ford shop (I hate taking my stuff to shops) and they checked everything and said it was fine. The lights are on cause a few wires have been rewired so some things dont read right. Plus they have been on since I bought it and I have replaced about everything you can. Hope you guys can help

I wouldn't take my truck there again. :shocked

What codes are you getting from the hack job on the wiring harness? Maybe it's something we can help you fix.

Yeah, I'd jack up all the wheels and spin them just to see if anything is hanging up.

An E4OD might be a nice upgrade for you too, you'd probably really bump your mileage up.
 

·
aka: kemicalburns
Joined
·
7,874 Posts
the zf 5 speed manual would be an easier upgrade and wouldnt require a wiring harness swap
 

·
Registered
Joined
·
11,108 Posts
the zf 5 speed manual would be an easier upgrade and wouldnt require a wiring harness swap
Very true... if you don't mind the idea of a manual, that'd definitely be the way to go.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #12
If i could find a decent priced used 5 speed I would swap it in. though the 3 speed is a great pulling/hauling tranny and great off road. just doesnt much like highway speeds. as for the wireing harness ya I know I hate fixing other peoples wireing nightmeres. It is getting close to time for a rebuild, about to turn 265,000 on it. If anyone has any other ideas shoot um my way. Im thinking right now maybe a tune up and tranny flush and new filters and such will help. thanks a ton guys
 

·
aka: kemicalburns
Joined
·
7,874 Posts
wow if the motor has that many miles that alone could be part of your bad mpg issue. do a compression test on all the cylinders and get back to us with the numbers
 

·
Registered
Joined
·
826 Posts
Id recommend tracking your actual mileage (MPG) rather than trusting the gauge, far more useful to have real numbers. My '96 gets 11 mpg this time of year.
Check your air filter and tire inflation. If those are both ok then check to see if your brakes a dragging. Right there ya got the top 3 fuel mileage killers.
Fuel filter and injectors would be lower on my list.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #15
Thanks guys much appreshate all the help. I have been a mechanic all my life but you know how it goes sometimes you get so caught up with other projects and helping other people with their cars you miss the simplest shit on your own. IM tearing into the truck this weekend and going to poke around. One thing I already fixed last night was the previous owners Hack job on the tranny cooling lines. Where the lines come by the bell houseing/back of motor they go right above the H pipe and below the starter. Well the genius who had this truck before much have had a leak in the tranny line so he hacked in a piece of rubber hose to fix it. Well i was driving thursday I smelled something burning and stoped right away. Looked under the truck and found that the spot he had patched was sitting right on the H pipe. Nice Hu. I figure since it was the tranny cooling return line it was probobly heating the fluid up before it got back to the Tranny and knocking off some miles. Since I fixed it I have picked up quick a few back. But ya new plugs, wires, Cap & Rotor, Coil, Fuel,oil,air and tranny filter. Fresh fluids, some Lucus oil treatment and tranny treatment. and a few other things. Should help a bit as well as looking for drag anywhere. The motor has a scedualed rebuild this spring. I got to get my talon running again so i have something to drive well I rebuild the motor. With as much as I love my Bullet Proof C6 Im afarid its time to swap in a 5 speed manual, espically with as much as I drive her on the highway. 3000 rpm's in third gear at 70 mph hurts gas mileage a bit you know. I wont complain about the 5 speed though since this is the first vehicle I have bought that has an automatic in it. Thanks again guys.
 
1 - 15 of 15 Posts
Top