Bronco Forum - Full Size Ford Bronco Forum banner

1 - 20 of 32 Posts

·
Registered
Joined
·
243 Posts
Discussion Starter #1
I've gotten so many problems lately with my damn truck its not even funny. Once again, it leaves me stranded on the side of the road...


So here is another problem. If i get this fixed, and i get another problem im selling the F'in truck :banghead:banghead:banghead:banghead


My truck will not shift by itself. When i parked the truck to put a new oil pump in it, everything was fine. I put the engine back on the mounts, get everything back together, and now it wont shift. My tranny used to be flawless. Went into gear perfect, shifted right, and pulled good with no slipping. Now, it will go into P R N D 2 1, but it will not shift in D. I have to manually put it in D, then drop it down to 2 then thats it. I actually got it to shift from 2nd to 3rd today. I had it in 2nd, runnin 4000RPM, threw it in D and it went into 3rd. But that happened once, and one time only.

I so far have :

adjusted my linkages, everything clicks into gear fine
new oil filter
changed the fluids
checked all wires around it, nothin is frayed or damaged

IDK WTF IS HAPPENING! Please help me out, and quick. Ive had nothing but problems with the SOB and im bout tired of it :banghead:smilie_slap
 

·
Age. Fac ut gaudeam
Joined
·
3,881 Posts
Burn it, take the insurance money and buy a Chevy.
 

·
Local # 40 Boilermakers
Joined
·
15,787 Posts
Are you saying that you now have to manualy shift all the time or it wont shift at all? If its not shifting by it self you might have pulled something loose when jacking the motor up.
 

·
Nvr Been Bnnd
Joined
·
8,675,444 Posts
what trans. is it?
 

·
Registered
Joined
·
9,790 Posts
AJ WTF is that all about????
i think hes trying to get us worked up again, but i just had my name mentioned in another thread, so im not takin the bait.

as for the shifting issue id say its prolly a loose vacume line. it prolly got knocked off or somethin when you moved stuff. the ony way to know for shure is to follow it. or maybe just put some tubing from HD in its place and see if that fixes it. dont give up on it, ive come close. last time that hapened i had shorted out the main power wire to the pcm and thought i had fried the computer. ended up being a fuse.:whiteflag its just something simple and stupid, at least it isnt something major like a chevy would be.
 

·
Registered
Joined
·
243 Posts
Discussion Starter #18
i think hes trying to get us worked up again, but i just had my name mentioned in another thread, so im not takin the bait.

as for the shifting issue id say its prolly a loose vacume line. it prolly got knocked off or somethin when you moved stuff. the ony way to know for shure is to follow it. or maybe just put some tubing from HD in its place and see if that fixes it. dont give up on it, ive come close. last time that hapened i had shorted out the main power wire to the pcm and thought i had fried the computer. ended up being a fuse.:whiteflag its just something simple and stupid, at least it isnt something major like a chevy would be.

tubing from HD?
 

·
Forward Some Money
Joined
·
5,028 Posts
You don't have to see it to test it at the transmission. Crawl underneath and disconnect it and check it running.

Yes, C6s were used in '87. I have one in my '89.

Technically speaking, it doesn't help the OP (to figure out his problem) if you guys guess at what it is or what transmission it may have. He already knows what it is and the chatter doesnt help him fix it.
 
1 - 20 of 32 Posts
Top