Bronco Forum - Full Size Ford Bronco Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Someone came to test drive the 96, I have not driven it in a while, cranked right up as always, I drove it first , kid was 15 years old, noticed spedo not working, abs light on, then shifting was not proper,no hazard lights, so from prior bronco experiences I knew it was 1 of 2 fuses, So I'm going to impress the kid with my marvelous skills, and low and behold all the fuses are good, i know all those functions are on fuse 13 or 18, don't remember the exact one, but please help me thanks rob 704-507-2453
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
It is a serious question, I thought you were being the smart ass when you said check the owners manual. As I stated in my original post, all the fuses are good, So what else in the ownrers manual will help me since I'm the dumb ass according to you?
 

·
Registered
Joined
·
258 Posts
Have you pulled any codes?

Do you have a Haynes Manual?

Do you have a Multimeter?

Have you checked the Flasher and light bulbs?

Your going need to do some work so you can post actual information that will allow these guys to help figure out what might be going on. You can use the multimeter to check if you have power running to the bulb sockets, if you do you have a bad bulb.

And the last bit of advise is you try and search before you post because there are several threads about the ABS light and speedometer.
 

·
Registered
Joined
·
224 Posts
I clicked the link and downloaded the owners manual. When I opened it I pressed "CRTL + F" and typed ABS and searched through some of the manually very casually and found a few things there too.

Fuses? Are you a Used Car dealer or something?

When you say No Hazard Lights, I think it's assumed that the 4 way flashers aren't working, or were you referring to the Check Engine Light as a Hazard light or something? IS the check engine light on? If so, pull the codes
 
1 - 5 of 5 Posts
Top