Bronco Forum - Full Size Ford Bronco Forum banner

1 - 8 of 8 Posts

·
Man of endless projects
Joined
·
9,234 Posts
Discussion Starter #1
I have been having a stupid problem with my truck that only happens randomly when i least expect it and the worse possible times. when i try and start the truck, the starter will do absolutly nothing but take all the power from the rest of the truck. try jumping solenoid and nothing different. hitting the starter with a hammer hundreds of times does nothing. manually turning the crankshaft doesnt help tho it does spin. i have to actually take the starter off, spin the gear inside it and remount it to get it working again. i have done this up to 20 times in 6 months now and on my third starter. this problem happens usually offroad but has also happened onroad aswell. any ideas what cuases this and how to fix it?
 

·
~*~*~*~*~*~*~
Joined
·
10,066 Posts
......the starter will do absolutly nothing but take all the power from the rest of the truck.......
When you say this ^^^^^ Does everything just seem to go dead, or can you hear the starter making any noise?

First and most important step to figuring out what is wrong here is to, clean all cables and connections. Battery post(s), cables, engine ground, starter relay, and connections on the starter should be nice and CLEAN. Inspect all cables for any frays, corrosion and replace if necessary.
 

·
Man of endless projects
Joined
·
9,234 Posts
Discussion Starter #4
its not the electrical, i have a new battery cable running to it and another for better ground. connections are good. what i mean by taking all the power is that it takes all the amps from the battery through it. only noise i here is a sound that is probably just the solenoid. the starters i get are from NAPA, where would i get one of those starters and how much are they. i just bought my last starter less than a month ago and the one before was only 6 months. is there any way to make this problem go away without another new starter?
 

·
Registered
Joined
·
215 Posts
if you have been banging on it with a hammer, its most likely shot, since the starters in bkos have a magnetic ring inside the case, my guess is you shattered it, and the broken bits are keeping it from spinning.
 

·
Registered
Joined
·
178 Posts
Some good ones on sale in the vendors section, LOL. If you have been hitting a smooth body starter with a hammer, Thadoggma is right, you have destroyed it. Not sure exactly what else it could be. Do you have an oil leak? Pretty common on the Ford PMGR to get oil on the armature, which causes it to appear dead shorted.
 

·
Registered
Joined
·
107 Posts
I've had the oil on the starter problem. It was weird that an oil leak could cause a no start condition but, its true. Good luck!
 
1 - 8 of 8 Posts
Top