Bronco Forum - Full Size Ford Bronco Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I had just come across this forum a few days ago and think it's awesome...I have a 96 Bronco XLT blacked out version. I've had some issues and can't believe that a little ground wire from the fender to the battery can make the whole truck go dead.
Anyway, I have an intermittent issue at times it really pulls to the right, I really have to pull it to the left to go straight and it just feels real tight. Then it feels like someone grabs the wheels with a little jerk and then it fine and seems to loosen up and act normal. This morning I put in 4wd low and noticed it pulling to the right and once I took it out of 4wd it went away.
Anyone have any ideas?
 

·
Registered
Joined
·
1,024 Posts
have you checked your brakes up front? if its pulling to the right in 4wd and 2wd maybe pads are jammed, alignment issuse?
 

·
Registered
Joined
·
77 Posts
is the wheel loose whe its not running? if you have automatic hubs, i bet one of your hubs is sticking. the reason people put manual hubs in is b/c you know for sure when theyre engauged. i still have auto hubs, b/c i dont wanna get out and switch hubs in the mud. i guess im lazy dammit. haha anyway, sometimes i have to drive in reverse for 100 ft to get my hubs to disengauge, but i still have one turn on in the road at random times. take ur hubs off and cut ur rotors while there off, replace pads, and re-grease auto hubs (since 4x4 brakes and hubs are the same pain in the ass). make sure to torque hub nuts to correct foot lbs, or ur hub will fall off!

beer and gasoline dont mix. choose wisely holy man!
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
yeah I have automatic hubs, I did notice the last time I washed it there was some grease coming out of the hub, more then I had say a year ago. The brakes were done before winter, but i didnt cut the rotors. I'll take a closer look at the hubs and rotors...
thanks for the info
 
1 - 4 of 4 Posts
Top