Bronco Forum - Full Size Ford Bronco Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,616 Posts
Discussion Starter #1
Ok, so I had to take the gearbox apart to place the sector shaft(?) seal in the gearbox. Everything went back in exactly as it came out. The problem is now when at left lock the truck won't return to center, I have to manually return the wheel to center. The interesting thing is, turning right (full lock) it has no problems returning to center, it's only left lock.
 

·
Registered
Joined
·
3,227 Posts
Id say the adjustments are too tight, but I dont know with it returning one way but not the other. Maybe a blockage in the valve?
 

·
Registered
Joined
·
1,616 Posts
Discussion Starter #3
I wouldn't think so? We kept the work area pretty clean and kept any dirt from getting inside the box as best we could. We never messed with any of the adjusting screws on the box, so I don't think that's it.

Would dirt in one of the hoses cause this?
 

·
Registered
Joined
·
1,864 Posts
It does sound to me like the sector shaft adjustment screw is too tight......I would try first marking exactly where it is now and then give it a 1/4 turn to the left....then lock it back down and give her a try.
Also just make sure there is no air in the PS pump/lines(turn the wheel from lock to lock....like that).......that may help with the wheel going back from one side and not the other.
 

·
Registered
Joined
·
1,616 Posts
Discussion Starter #6
Streetgang said:
It does sound to me like the sector shaft adjustment screw is too tight......I would try first marking exactly where it is now and then give it a 1/4 turn to the left....then lock it back down and give her a try.
Also just make sure there is no air in the PS pump/lines(turn the wheel from lock to lock....like that).......that may help with the wheel going back from one side and not the other.

I'll have to give it a try tomorrow. The system was fully "bled" if you want to call it that, so there's no air in the system.
 

·
Registered
Joined
·
1,616 Posts
Discussion Starter #7
Streetgang said:
It does sound to me like the sector shaft adjustment screw is too tight......I would try first marking exactly where it is now and then give it a 1/4 turn to the left....then lock it back down and give her a try.
Also just make sure there is no air in the PS pump/lines(turn the wheel from lock to lock....like that).......that may help with the wheel going back from one side and not the other.
Ok, I gave it a try. It did help with the truck pulling to the left at speed, it doesn't pull nearly as hard but when making a sharp turn she'll head straight to left lock after a certain point. If I had the power I could do donuts all day long without ever touching the steering wheel after the first circle. There's still more to play with so I guess I'll mess with it some more tomorrow.

badass1tonf100 - I may end up doing that if I can't get this thing straightened out. Thanks.
 

·
Registered
Joined
·
1,616 Posts
Discussion Starter #9
Affirmative.
 
1 - 9 of 9 Posts
Top