Bronco Forum - Full Size Ford Bronco Forum banner

Still high rev after putting in park!

2104 Views 7 Replies 4 Participants Last post by  90.CaliBronco
1990 XLT, 5.0

Symptom: High engine rev constant at (1400 rpm) when putting bronco back in park after driving, when driving idle is perfect at 650 rpm. After engine is warmed up though, stopped at a light i do get random surging small but noticeable and today it just stalled on me at a light. Started back up but seemed to struggle like it was binding or had no power. No check engine light warning.

Tried Fixes:

Replaced all vacuum lines with silicone lines (a/c works great now) didn't help

Replaced the stock IAC (400k miles and never replaced) - didn't help

Saw that the throttle cable plastic was broken, so replaced the throttle cable thinking it could be sticking - didn't help (also my cable was abo 38" but could only find 40" so now its really hard to pedal down on the accelerator, any help?)

Fed up took it to a local shop that always has box mustangs, broncos and f150s out front, they found the lower intake manifold gasket was causing an air leak, so got the gasket kit and fixed that. still no dice.

Could I be missing something?

Other things to note, whether helpful or not:
installed new PCV and hose to intake as mine was completely missing
installed used TAB as mine was missing and smog pump went straight to TAD (flows fine)

Mods to engine when I rebuilt it in 2004 (50-60k miles on engine since) abo 40k miles on the E4OD tranny
Comp Cams Ford EFI Truck Cam (can't find the info on it anymore, the receipt only states this)
K&N Intake
Electric fans
Basani Headers, hi-flow cat, Basani exhaust
130 amp alternator
See less See more
1 - 1 of 8 Posts
Sounds like vacuum leak but you confirmed thats not it. 3 more things come to mind. Throttle plates not closing all the way, bad ECT sensor, new IAC is bad. Pull codes to look for electrical issues.

Sent from my SM-N960U using Tapatalk
1 - 1 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.