Bronco Forum - Full Size Ford Bronco Forum banner

1 - 4 of 4 Posts

·
green ones make me horny
Joined
·
11,135 Posts
Discussion Starter #1
Here is the original thread.

http://fullsizebronco.com/forum/showthread.php?t=171816

I am still having this problem. just without the codes now. Basically the truck is running really rich to where it stumbles and then surges. it does this for about 10 seconds if that then acts normal, kind of like something is sticking. So far i have replaced the following:
- TPS
- MAF sensor
- IAT
- IAC
- VSS
- O2
- TFI module passed test

The only thing left in the loop would be the ECT sensor. I got the homeboy hookup right now so im getting my parts free/dirt cheap so i dont mind throwing new sensors at it. Upon searching and reading it seems like there is a sticking Fuel Pressure Regulator. like it sticks, floods the engine, then it gets unstuck (for lack of better terms) and corrects itself. I performed fuel system test already. everything is fine accoring to the haynes manual. meaning leakdown, key on engin off pressure, engine running pressure. no faulths there. im at my wits end. i thought i had it fixed, ran fine this past weekend then just started doing it again today.

any help would be greatly appreciated.
 

·
Registered
Joined
·
1,382 Posts
Could be that Fuel Pressure Regulator. If it runs good and then all the sudden runs like crap could be diaphragm failure when running (when u can't see FP). Is ur thermostat in backwards?
 

·
green ones make me horny
Joined
·
11,135 Posts
Discussion Starter #3
No tstat is in right. All the cooling stuff is new. just repalaced all that. like i said it will run great for a week then all of the sudden bam. acting like it is getting fuel dumped into it. like having a shitty carb on there, you know what i mean. i think im going to replace the FPR and go from there. will probably do the ECT as well since that is the only EFI related sensor that hasnt been changed....lol
 

·
OMG its almost a
Joined
·
1,367 Posts
What was the outcome here? I'm fighting a similar problem and just wondering. Mine has ran fine for years and I took it to a shop for new tires and they called me, said it won't start. It's got fuel and spark but I can smell fuel like its flooding out. I'm leaning toward FPR or EEC Relay right now.
 
1 - 4 of 4 Posts
Top