Bronco Forum - Full Size Ford Bronco Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
i just installed a 6" rough country lif and some 35" pro comp mudds, but in full terms my tires rub on the sway bar. i was wondering if anyone else had this problem and what i could do to fix it
 

·
Registered
Joined
·
741 Posts
you wont notice much onroad difference after taking off the swaybars but a little more body role, just remeber its not a sports car its a bronco so drive it like a bronco. Now off road you'll notice a big difference while flexing. So just hackem off.
 

·
College User
Joined
·
2,013 Posts
I got mine on still, am I whells at least twice a month, hard and crazy style. Might remove the rear soon, and I do rub on the front but dont really mind.
 
9

·
Guest
Joined
·
0 Posts
Mine are on.


I didnt like it with it off. My pivot bushings are crap and i swear the sway bar holds my front end together. I dont want to spend any more money on my TTB., i want a SAS. And, my rig was really crazy wobbly without it in the front. So i put the sucker back on.
 

·
Premium Member
Joined
·
10,513 Posts
94_chickentaco said:
Mine are on.


I didnt like it with it off. My pivot bushings are crap and i swear the sway bar holds my front end together. I dont want to spend any more money on my TTB., i want a SAS. And, my rig was really crazy wobbly without it in the front. So i put the sucker back on.

Taco my man .. you are a brave soul to admit that :toothless



terrible1 .. check this link http://fullsizebronco.com/forum/showthread.php?s=&threadid=5409
 
1 - 19 of 19 Posts
Top