Bronco Forum - Full Size Ford Bronco Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
1,505 Posts
Discussion Starter #1
I'll get to the pics in a little bit, first off, a small story. I spent some time a couple weeks ago prepping for this run.

http://fullsizebronco.com/forum/showthread.php?t=117182

To make a long story short, I needed my hydro assist (welded front) and it wasn't finished until about 5 minutes before we took off. Lucky for me, it worked flawlessly. Here are a couple pictures of it. The oil spots are from the install.







We (my buddy and my two brothers) left around 10AM on Friday to travel to Ocotillo Wells where the event is put on by Tierra Del Sol Club. They do an awesome job.

Got to camp a little after 1pm and got everything set-up and registered. After a quick trip around the vendor booths, we went out for a run. The first hill I took a bad line and came very close to rolling over backwards. I was balancing on my rear tire and the sidewall on my front (sorry no pics, everyone was in the bronco).

We wheeled the small rock trails close to camp and did some go fast in the washes, well, as fast as my rig can handle..... :goodfinge





We had a good time around the fire on Friday night. Broke some pieces off an old 1356 and burnt them (magnesium alloy), lit up our campsite like it was day time.

Then we lined up for the Saturday organized run, lots of jeeps.





Got into some notches (washed out areas of the desert) and widened a few.





Crazy people with open diffs...



I ended up following a couple Early Broncos through a notch. Between this spot and another, this one managed to toast his tranny and had to be towed out.









The wind REAAAALLLLLYYYY came up Saturday evening. While we were at the raffle out tent was destroyed. If we did not have a bunch of crap in it, it would have probably blown to Mexico. We decided to pack up and head for home about 10pm on Saturday, but all-in-all a good time.

The rest of the pics are located HERE
 

·
Registered
Joined
·
1,505 Posts
Discussion Starter #2
Forgot to add, the only carnage (besides some body damage and some DEEEPP rock scratches) was to one of my batteries. My body flexed enough to allow my york pulley to get the battery. Looks like I need a couple new dry cell batteries......



Also, I think my front diff breather is clogged and it allowed my front diff to build enough pressure to blow out my (BRAND NEW) long side axle seal. I'll pull it apart this weekend.
 

·
Registered
Joined
·
3,722 Posts
Glad to hear everything is still together Scott. Sounds like we need to connect the body to the cage. Ha! This pic rocks!

 

·
Registered
Joined
·
1,505 Posts
Discussion Starter #5
My buddy did that sticker. We bought some skateboard helmets to wear in the bronco and they came with those stickers. He put the sticker there not knowing anything about BroncoSpeed..... I thought it was kinda funny as well.

We bounced around a lot and didn't even come close to hitting the cage so I think we did a good job of placement.

Also noticed I'll have to change out my steering stops or clearance my yukon stub axles as they were hitting on the yokes at full lock.

This was the first trip on my 60 and my hydro assist so I was putting a lot of faith in both set-ups. I will say they were both well worth the time. I absolutely hammered (read full throttle assaults) my bronco through stuff and the front end just laughed. I mean bouncing off the rev limiter going lock to lock type stuff, good times. I thought my 36's would allow my front diff to hit a lot of stuff, but now seeing what I made it though without hitting too many diff rocks, I think I'll only jump to 39.5's or 40's.
 

·
Registered
Joined
·
1,505 Posts
Discussion Starter #7
The driveshaft fit perfect. I had to do a little grinding on the yokes but I knew I would have to for get it to not hit at full droop.
 

·
Registered
Joined
·
3,424 Posts
Nice pics man! You interested in running for full size of the month?
 

·
Registered
Joined
·
457 Posts
Nice pics.
 
1 - 14 of 14 Posts
Top