Bronco Forum - Full Size Ford Bronco Forum banner

1 - 6 of 6 Posts

·
Banned
Joined
·
238 Posts
Discussion Starter · #1 ·
1988 302 5.0 EFI
I just replaced the coolant temp sender switch thinking it was bad. When I run my truck for a while the temp needle will not go past the N (normal) is this normal?? I always thought the needle was suppose to run in the middle.
could it be my thermostat, water pump or am i just freaking out?
 

·
Roller rockers are gay
Joined
·
19,191 Posts
change your thermostat, it's probably stuck open.

and while you're in the, do a coolant flush.

they don't have to ride "in the middle" my bko never went past R, and my F150 has only gone between "O R''.
 

·
Registered
Joined
·
728 Posts
there might be two, I was just monkeying around with mine tonight, one hooks up the computer, the other goes to the instrument panel, atleast thats my understanding, which on is which? well if its a single wire that should be the one that goes to the panel, mine is in the lower intake manifold front driversside
the computer one that maybe you replaced thinking it would change your panel indication is on the passenger side on the other side of the dizzy
 

·
Banned
Joined
·
238 Posts
Discussion Starter · #4 ·
kaudbron said:
there might be two, I was just monkeying around with mine tonight, one hooks up the computer, the other goes to the instrument panel, atleast thats my understanding, which on is which? well if its a single wire that should be the one that goes to the panel, mine is in the lower intake manifold front driversside
the computer one that maybe you replaced thinking it would change your panel indication is on the passenger side on the other side of the dizzy
the one i changed is on the drivers side below the distrubutor. (single wire)
 

·
The Anti Yam!
Joined
·
22,674 Posts
tucker1251 said:
the one i changed is on the drivers side below the distrubutor. (single wire)
Thats the one for the gauge.


Get a mechanical gauge and see what is really happening.
 
1 - 6 of 6 Posts
Top