Bronco Forum - Full Size Ford Bronco Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
394 Posts
Discussion Starter #1
Hey everyone! I hope everyone is doing great!
I just finished getting all the plastic vacuum hoses out of the 95 5.8L
I was hearing some pretty loud hissing combined with a high idle which kicked off this whole deal I have been procrastinating on forever now.
I noticed this hose (see pictured) coming out of the intake manifold and passing around back to a check valve. It appears I lost a hose clamp and it was just sitting in the hose / very loose / off. You guys know its a pain to see back there, I went in armed with a few pics downloaded from previous posts. Any chance you know where this hose connects to? I got the old hand feeler back there but didnt find any mate points.





Many thanks in advance


Mike
 

·
Registered
1984, 300 L6, smogless, manual 3speed with overdrive.
Joined
·
1,454 Posts
Fuel injected?
 

·
Registered
1996 EB 5.8L, E4OD, 2.5" RC Lift, 33" tires, 3.55 gears
Joined
·
103 Posts
Don’t hold me to it but i think it should be capped. At least on my 96, I just have one line coming from PCV to intake.
 

·
Registered
Joined
·
162 Posts
What you have pictured is the PCV hose.
My '95 351w looks just like that. No cap on the extra nipple, but if you look closely, it is sealed closed.

Make sure you use EEC replacement hose for anything that deals with the emission system, otherwise it may deteriorate quickly.
 

·
Registered
Joined
·
394 Posts
Discussion Starter #6
You guys were right. Plugged. And let me tell you, with it off and the motor running its whistler!

Thanks again!
 
1 - 6 of 6 Posts
Top