Bronco Forum - Full Size Ford Bronco Forum banner

1 - 6 of 6 Posts

·
I'm stuck :)
Joined
·
724 Posts
Discussion Starter #1
This morning i started my truck so it could warm up some before heading off to school. i let it sit for a good 20 mins and the temp gauge still read cold? i drove my truck around for an hour after school... still says cold. The gauge will move to just below normal and it thats were it stays. could this be a bad thermostat? or maybe its stuck its only like 8or9 degrees here so. idk HELP
 

·
Registered
Joined
·
132 Posts
Does the actual radiator get warm? Could be a bad sending unit, but I wouldn't start swappin parts yet. Ever had it in sub-freezing weather before? My '66 f series w/ a 390 and a 4 core radiator is worthless as a heater when I take it to the snow. Between the thermostat bypass and that fan making it into an aircooled motor, it never gets anywhere near warm.
 

·
Registered
Joined
·
2,279 Posts
Like Cali said, could be the t-stat could be the sending unit, could be the gauge, could be a wire...etc etc etc. As mentioned, does your heat put out hot air? If not then your coolant isn't warming up which would signify that your t-stat is probably stuck open (might be closed but you'd probably have overheating problems if that was the case). Granted yeah you could also have heater core problems or a number of other things but the t-stat is probably a pretty safe bet I would think. Plus they are dirt cheap and not hard to replace or you could pull yours and look at/test it (drop it in boiling water, see if it opens, take it out and set it on the counter, see if it closes) and then buy a new one or just buy/make a new gasket if you don't want to buy it...
 

·
Registered
Joined
·
405 Posts
Easiest way to tell is to grab the top radiator hose and then the bottom. If one is hot and the other is cold, your radiator is plugged. If they are the same, it's the thermostat.
 

·
Registered
Joined
·
6 Posts
If you figure it out, let me know. Mine has been doing the same thing since I got it. And I'm from Alabama, so its not that cold.
I had been thinking sending unit.
 

·
Banned
Joined
·
5,463 Posts
my truck would run cold before. The coolant gauge would never move. The t-stat got stuck open. I was pretty surprised because it was a year old and the premium or "heavy duty" t-stat from the parts store.
 
1 - 6 of 6 Posts
Top