Bronco Forum - Full Size Ford Bronco Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
How do I go about replacing or fixing the plug? any advise would be greatly appreciated.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
I'll describe it as best as I can. I have an adapter that's used to plug into the FSB plug under the truck. OK, well I did that and only the left side of the lights light up. Blinkers, hazards, and brake lights only work on the left side. Very odd.:cry This is the first time I hook up anything to the FSB. I checked both bulbs and both are working. Thanks for any info. :thumbup
 

·
Registered
Joined
·
331 Posts
ok, did you just put the trailer light harness in yourself or are you trying to diagnose a problem that you inherited? Is it the regular 4 pin flat connector, 6 or 7 round? either way get the diagram for the connector you are using and trace each individual wire form connector back to its splice... if the lights are working on you bronco and not at the trailer connection then more than likely its the splice connection that is your problem...
 

·
Registered
Joined
·
18 Posts
Discussion Starter #6
I'm thinking the issue is with the plug/harness on the FSB. I hate wiring!:barf Thanks for the info. gents. Have a great Monday.
 

·
Premium Member
Joined
·
4,530 Posts
Not sure about a 94 But my 96 had fuse's under the hood just for the trailer lights. Pop the fuse box under the hood and make sure all the fuses are good under there first before you go checking wire harness's. I had the same issue but only the DS blinkers were working I think. I had several blown fuse's.

Got my bronco owners manual for a 96 and my fuse's for trailer lighting are:
Fuse#4 - Trailer backup lights/trailer running lights
Fuse#6 - Trailer right hand stop/turn lamp
Fuse#7 - Trailer lefthand Stop/Turn lamp
Fuse#18 - Trailer Battery Charge
Fuse#21 - Trailer Brake feed
Relay#4 - Trailer tow running lamps
 
1 - 8 of 8 Posts
Top