Bronco Forum - Full Size Ford Bronco Forum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter · #1 ·
Hello. I have a 1994 Ford Bronco XL. Not sure exactly what transmission I have but I do know that it is a 4 speed Automatic. When driving down the road it feels as thought my transmission kicks into neutral and after a few seconds of my motor revving to the moon, it slams into gear. It usually happens so fast that I cant take my foot off the gass in time. Any suggestions??
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #3 ·
The thing is is that sometimes it shifts just fine. But others it shifts real hard. So I'm not entirely sure where I should begin looking
 

·
Registered
Joined
·
144 Posts
Pull the codes, it will give you an idea where to start anyway. The same thing happened to my 94 and it turned out to be the TPS
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #5 ·
Thanks guys. I'll see what I can do and I'll keep you posted. 194K miles and still going strong. Thanks
 

·
Service before Self
Joined
·
136 Posts
I had a similar problem with mine. It seemed to shift into neutral then when I stepped on the gas it would rev and them slam back into gear. It wound up being my transfer case. The shift fork broke and it was slipping into neutral when the drive train got slack in it then it would slam back into place when I stepped on the gas. It happened when I was on a road trip and still about 4 hours from home. It made it the rest of the way back but the problem kept getting worse and it grenaded when I got off the exit ramp at my exit....
 

·
Registered
Joined
·
11,116 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter · #8 ·
I'm sorry but what in the hell is an MLPS??
 

·
Registered
Joined
·
144 Posts
It's the manual lever position sensor, it replaced the neutral safety switch on newer cars. It's on the side of the transmission. It just plugs in.
 

·
Satyr of the Midwest
Joined
·
17,738 Posts
Have you tried the "Search" function yet? :toothless
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #12 ·
I have never heard of that but in either case I'll have it checked out. Any other ideas on where to look?? I appreciate all the help by the way
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #14 ·
I'm from Southbridge MA. Over near Worcester.
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #16 ·
Oh nice. I've got friends in Tolland and near Hartford. My sis goes to school at UHA
 

·
Registered
Joined
·
2 Posts
Can that same problem cause Bronco's idle to fluctuate too.
 

·
Registered
Joined
·
11,116 Posts

·
Registered
Joined
·
76 Posts
does your dash lights and still work?lol..cause ford uses tha same fuse for Electronic shift in tha e40ds as they do for tha dash lights and tail lights and when it blows it shifts like hell..
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #20 ·
My dash lights work fine. Everything works just fine. I just need to get that problem checked out. I'll try and have the codes yanked this weekend
 
1 - 20 of 24 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top