Bronco Forum - Full Size Ford Bronco Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
57 Posts
Discussion Starter #1
hey guys i know yall are ford guys.. me too but i have an 83 chevy silverado 4x4 and i took it muddin a few days ago it ran perfrect even when i got home the same day it was fine. the next morning i went out to drive it and it will not crank, it will turn over with the key but she wont fire up.. doesnt sound like it wants to crank unless i flood the gas and turn the key it will fire just one time then nothing... someone told me to check the distributer cap and check for water but i didnt see nothin.. usually a 350 will run through anything but this ones got me stumped..:banghead any help is appriciated!!!!
 

·
Registered
Joined
·
777 Posts
Hmm, remove broken Chevy, and replace with Ford :rofl:

83. is that TBI? small cap or large cap HEI?

Good luck getting to the distributor WAAAAAAY back there.

Cheers

Steve
 

·
Kitteh Commandaar!
Joined
·
4,191 Posts
hey guys i know yall are ford guys.. me too but i have an 83 chevy silverado 4x4 and i took it muddin a few days ago it ran perfrect even when i got home the same day it was fine. the next morning i went out to drive it and it will not crank, it will turn over with the key but she wont fire up.. doesnt sound like it wants to crank unless i flood the gas and turn the key it will fire just one time then nothing... someone told me to check the distributer cap and check for water but i didnt see nothin.. usually a 350 will run through anything but this ones got me stumped..:banghead any help is appriciated!!!!
Well, as borflink said before, your problem is its a chebby. :rofl:

Your post is very confusing and contradicting. Cank and turn over are the same thing (In my book anyhow), so be careful with your wording.

The way I understand your post is that your motor turns over, but it will not fire.
Did you check for spark?
Did you check if your getting fuel?
Did check your important ignition connections for water?


KC
 

·
Registered
Joined
·
777 Posts
well, there ya go. check the power wire going into the cap. got power? if so, then it's something inside. can't help you there, it's been 20 years since I've been in an HEI.

Cheers

Steve
 
1 - 7 of 7 Posts
Top