Bronco Forum - Full Size Ford Bronco Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
369 Posts
Discussion Starter · #1 ·
so i borrowed the battery out of the bronco for something else and go to put it back in and like a dumbass i put it in backwards and put the cables on jus assuming that it was rite lol.. so i went to crank it and nothing then i smelt sulfur... Does anyone know what i would have blown? I have no power to the truck i havnt tried a different battery but would i have fried the battery when that happen to? Any help would be great thanks
 

·
Premium Member
Joined
·
23,551 Posts
you probably blew some fuseable links and fried any ignition parts like the duraspark box, coil.
 

·
Registered
Joined
·
2,578 Posts
There are diodes in the alternator, they may have burnt up too.
Pray that the fuseable links protected everything.

I'm certainly not an expert, but I pretty much think that the coil wouldn't have been damaged.
 

·
OMF
Joined
·
2,973 Posts
At least it is a '78 and it doesn't have a computer!!!
 

·
4:20 Enthusiast!
Joined
·
3,277 Posts
My kid tried turning my battery around to have the connections inside the engine bay as opposed to towards the front.Guess what happened next?:smilie_slap
Make sure you check all your fusable links.I had to change my ingintion switch out,solonoid and a few links near the solonoid.It made a world of difference.
 

·
Registered
Joined
·
369 Posts
Discussion Starter · #8 ·
My kid tried turning my battery around to have the connections inside the engine bay as opposed to towards the front.Guess what happened next?:smilie_slap
Make sure you check all your fusable links.I had to change my ingintion switch out,solonoid and a few links near the solonoid.It made a world of difference.
thas wat happen to me man i put the battery in how it looked like it was but it was backwards wasnt payin attention lol
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top