Bronco Forum - Full Size Ford Bronco Forum banner

1 - 13 of 13 Posts

·
Registered User
Joined
·
1,407 Posts
Discussion Starter #1
when cruising then turning on the right signal my trans slips like its going into neutral. happens for a sec then catches itself. anyone ever hear of this or know whats causing this? i've never seen this before:shrughappens with cruise control on and off.
 
K

·
Guest
Joined
·
0 Posts
my advice would be to just check all of the wiring that has to do with the turn signal, and see if theres a problem there... never heard of that? :shrug
 

·
But what does mine say?
Joined
·
954 Posts
Yeah, I guess it's pretty common. It's E4OD right? I wish I could remember the cause. I'll look for ya!
 

·
Registered
Joined
·
2,400 Posts
Try using the turn signal lever on the LEFT side of the steering wheel.
JK
 

·
Registered User
Joined
·
1,407 Posts
Discussion Starter #8
Miketnf150 said:
Don't use the turn signal when turning right, instead stick your arm out the window to signify a right turn.....:toothless :histerica :slap :histerica

Problem solved!!!:thumbup :thumbup
i already thought about that one

the dell computer tech guy said my blinker fluid was where it needed to be:goodfinge
 

·
Registered
Joined
·
35 Posts
Had the same problem, the hard wires in the blinker were off and caused the brake light to flash, made the cruise control think you hit the brakes. Had a H*LL of a time trying to align it, ended up replacing the whole switch. Solved the problem.

Good luck
 

·
Registered
Joined
·
1,340 Posts
ROTFLMFAO...I thought I was going nuts but mine does the cruise control thing too when I turn the right hand turn signal on lol.
 

·
Registered
Joined
·
3,371 Posts
yes it will. i'm not sure how exactly, but i had some melted wires in my collum, the turnsignal wires were melted, and it screwed up my tranny so bad, that it burned up my shift pack, and the truck only had reverse and 3rd gear. i dont know why the turn signals were in with the tranny, but it was one of about 50 different circuits that had to be isolated to figure out the elect problem my tranny was having. thats how the burnt turn sig wires were found. fixed that and i was good to go.
 
1 - 13 of 13 Posts
Top