Bronco Forum - Full Size Ford Bronco Forum banner

1 - 5 of 5 Posts

·
Screw the Jeep Thing
Joined
·
4,522 Posts
Discussion Starter #1
Anyone ever had this issue? I'm not sure if it's causing my other issues, but I'm thinking it is.

Saturday I was bring my truck out ot my parents to park it for the winter. All was great cruised at 60-65 (Speedo is off about 10%). as I started going up a slight corner to a long hill I floored it. All wass well till about half way up the hill, it started pulling hard left. I left off the brakes and it started pulling hard right. As long as I was on the gas it pulled left. When I stopped at the stop light the steering wheel whipped out of my had about 3/4 turn to the left. Started going again and heard a loud pop, and the truck drove normally again..

Got to my parents, parked the truck and noticed the passanger hub was had half a turn on it. There was no pressure at all on the cap like their normally is, on either side.. The shaft on that side is a tiny bit long and puts a little pressure on the cap itself.

Could this be the cause of my issues? I'm hoping it's not the detroit, if it is I'm going to have to be really pissed. But It seemed to spin both tires just find when I floored it in the snow.
 

·
Registered
Joined
·
317 Posts
Remove both warn hubs and inspect them. If you don't see anything wrong, switch them to the opposite sides and see if the pulling changes from left to right.
 

·
A broke kid with a bronco
Joined
·
4,065 Posts
I'm thinking the springs in the screw part of the cap broke. Or the actual locking portion of the hub. Pull the hub body and take a look.
 

·
Premium Member
Joined
·
3,944 Posts
broken spring in the locking portion. how long have you had the locker??
 

·
Premium Member
Joined
·
5,396 Posts
broken spring, or the inner part of the hub is cracked (or for some other reason) sticking and not sliding properly.. take apart, clean, inspect.. it'll probably be fine.

sounds like you have offset rims.
 
1 - 5 of 5 Posts
Top