Full Size Ford Bronco Forum banner

9821 - 9840 of 18418 Posts

·
Premium Member
Joined
·
1,900 Posts
I replaced the normal rear window with a stock defrosting window I picked up at the PAP a few weeks ago. I also replaced the window seals and upper guide track rubber on the shell. Tried to replaced the lower tailgate seal, but could NOT get any of the screws holding the real molding/trim out, even with a drill, so that will have to wait. I also changed the oil and did a damage assessment from my little trail ride a few weeks back. No real damage, but I need to clean out some mud from the hard to reach places. I wish there was a car wash with a lift so I could powerwash the underside real good.
 

·
Registered
Joined
·
322 Posts
Today thought real hard on what could possibly be causing the oil leak on the drivers side. Wish I knew other FSB members that live nearby to me for some help. At the moment, the transmission's acting screwy, it moves forward in reverse and neutral and that oil leak just kept getting worse. I really don't want to get rid of it but if the engine's ****ed then I'll have no choice, since I can't afford to replace or repair it.



Keep your fingers crossed....



D2k15!
 

·
House of Windsor 4ever!
Joined
·
10,443 Posts
At the moment, the transmission's acting screwy, it moves forward in reverse and neutral.
First blush, it sounds like the shifter indicator, shifter and/or trans manual lever are out of adjustment with each other. There are procedures for verifying and resetting all three of these. Does the trans have the starter safety switch on it? If so, that's where I'd begin to check. These have to be verified before you start looking at the trans internals (bad/stuck solenoids can cause this problem also).
 

·
Use the Force...
Joined
·
968 Posts
When I put my AOD in, the notched selector lever inside wasn't lined up right with the valve body piston and caused this. Drop the pan and make sure it's installed properly. If off, it causes the valve body to only partially engage the gears and disrupts the pressure flow.
 

·
Registered
Joined
·
322 Posts
First blush, it sounds like the shifter indicator, shifter and/or trans manual lever are out of adjustment with each other. There are procedures for verifying and resetting all three of these. Does the trans have the starter safety switch on it? If so, that's where I'd begin to check. These have to be verified before you start looking at the trans internals (bad/stuck solenoids can cause this problem also).


No, I wish it was that. But the solenoid pack was on its way out for a while anyways and this is just the beginning of the end for it. Fortunately I ordered and received the replacement a couple weeks ago. I was holding out for warmer weather to work on switching it out but didn't work out that way. While I do that I'm changing the filter and gasket out since I have to switch the fluid out anyways. Add another oil change in the mix and it's gonna be a real busy day.





D2k15!
 

·
Registered
Joined
·
9,129 Posts
Traced my stuck steering problem to the power steering box, backed off the adjuster all the way and its a bit better now. Washed it clay barred the hood, then wax. I don't remember the last time it looked this nice.
 

·
~*~*~*~*~*~*~
Joined
·
9,757 Posts
Changed my fuel filter. Engine has been feeling like it's been starving for fuel. All I can say is....YUP!!! IT HAS!!!

I think the last time I changed it was back in 2003 :scratchhe :brownbag
 

·
Premium Member
Joined
·
3,993 Posts
Here's a few pictures of how it was when I got it. After further inspection it doesn't have as much rust as I'm used to but it does have it's fair share. Also it has some body damage and the interiors shot.
Might be worth sealing up and storing in your back yard for 10 yrs when your current one rusts to dusts.
 

·
Registered
Joined
·
95 Posts
Finally got around to replacing my vacuum hoses. Now I really need to replace my u-joints. I was hoping on taking the day off work an gettig that done, but that didn't happen
 
9821 - 9840 of 18418 Posts
Top