Full Size Ford Bronco Forum banner

101 - 120 of 18914 Posts

·
Registered
Joined
·
101 Posts
I broke off a bolt in the spindle that hold a sensor cover, then used an extractor to get it out, chewed the hell out of the cover, but the spindle is fine
 

·
Registered
Joined
·
592 Posts
New MM Supremes on. Looks so much cleaner than the OEM. Especially with the chrome outer ring, and the rear wheel center caps.





Then I hung the top from the garage.
 

·
Premium Member
Joined
·
4,772 Posts
Cleaned the surface rust off the front floor pan and sprayed rustoleum converter over the area. Reinstalled the radio and speakers and played it for a few hours straight with no issues.

So far.
 

·
Registered
Joined
·
273 Posts
Retorqued the lift, installed new door speakers (nothin fancy) and turned my steering stabilizer around...it was hitting on the front lower shock mount.:tinfoil

I prayed over it in the hopes that God will have mercy on the poor beast and not let anything else break.......
 

·
Registered
Joined
·
1,037 Posts
Crippled it. Haven't had Death wobble in 6 months, and I sold the Hawgs, so I mounted up my 4 bald Irok 39.5 Bias spares (already mounted on rims, just bolted them to the Cent), and Geezuss! couldn't drive across town. Shake Rattle and Roll BAY-BEE!!!!

Gonna limp it to work tomorrow, where I will bolt on the 37x12.50's that replace the Hawgs.
 

·
Kitteh Commandaar!
Joined
·
4,198 Posts
I touched its tailpipe and told it that it was good girl :toothless:

Nothing...not a damn thing since about this time last year. :cry:

KC
 

·
JEEP CREEP
Joined
·
2,503 Posts
cleaned her up alittle. getting the tools out tomorrow to finish trimming up the rear quaters. and mybe hacking off the bumper to start building another one
 

·
JEEP CREEP
Joined
·
2,503 Posts
i finally mounted the switches for all my lights on the dash. i got tired of them laying in the floor with wires going everywhwere
 
101 - 120 of 18914 Posts
Top