Full Size Ford Bronco Forum banner

17121 - 17140 of 19307 Posts

·
Registered
Joined
·
130 Posts
No, you have so little gas in the tank, it's not drawing anything up. The fuel pump module is hard-connected to the hanger. The (I assume) steep angle put the last of the gas out of the pump's reach. I did this once in my '97 Exploder; I was facing down a steep street, running low on fuel, but with the engine idling to stay warm, and it died. Fortunately, I missed a tree as I coasted the truck into the alley, cycled the key a few times, then fired her right up. I found a parking spot on the connecting avenue, and no more chance of a problem when I fueled up.


I wish it was that easy. I’ve got just over 3/4 of a tank. Changed the fuel filter and with it removed I turned the key to run and nothing came out. So I definitely have something wrong in The tank.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
376 Posts
I wish it was that easy. I’ve got just over 3/4 of a tank. Changed the fuel filter and with it removed I turned the key to run and nothing came out. So I definitely have something wrong in The tank.


Sent from my iPhone using Tapatalk
Verify you have power from the fuel pump relay first, or jump it and see if it jogs.

You can probably kick the tank a few times or smack it with a 2X4 to get it to run if you need to move it before dropping the tank.
 

·
Registered
Joined
·
130 Posts
Verify you have power from the fuel pump relay first, or jump it and see if it jogs.



You can probably kick the tank a few times or smack it with a 2X4 to get it to run if you need to move it before dropping the tank.


I swapped the relays around and still nothing. I’ll fiddle with the wires and a multimeter once I get the access hatch cut.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
130 Posts
Verified that the pump was bad so I went ahead and changed it out. Now she runs again. I can’t believe parking with one side up on a pile of snow caused the fuel pump to go out...


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
367 Posts
Was going to install the HD wiring harness yesterday but the rain kept me in the garage working on the skiff.
 

Attachments

·
Premium Member
Joined
·
367 Posts
Just got home and installed new tailgate cable supports. T50 torx. Also checked the Torx bolts for the shifter under the column. Thanks Latvius.
 

Attachments

·
Premium Member
Joined
·
1,265 Posts

·
Eric
Joined
·
2,560 Posts
Found out that ordering new wheel bearings is a PITA if you have top-hat hubs. I like my top-hats, but this might just sway me towards a standard-hub conversion when I get around to rebuilding the front axle here in the next couple months.
 

·
House of Windsor 4ever!
Joined
·
10,494 Posts
Found out that ordering new wheel bearings is a PITA if you have top-hat hubs. I like my top-hats, but this might just sway me towards a standard-hub conversion when I get around to rebuilding the front axle here in the next couple months.
Believe me when I tell you, as far as strength, top hats just don't have it. Change to standard hubs as soon as you can.
 
17121 - 17140 of 19307 Posts
Top