Full Size Ford Bronco Forum banner

17361 - 17380 of 18418 Posts

·
Registered
Joined
·
264 Posts

·
Registered
Joined
·
4,578 Posts
That’s the one. Got mine in the other day, but no slit. Easy enough to make one though.




Sent from my iPhone using Tapatalk
That's weird, I was up at JBG on Monday, and spent my $9 on one, and it was split. Maybe they have multiple suppliers.

BTW, for those of you that are somewhat local to JBG (Jeff's Bronco Graveyard), they have changed their retail model, and now they want you to place (call in) the order 24 hours before picking it up. I didn't do that, but they took my money (I bought more than just the sleeve) anyway.
 

·
Premium Member
Joined
·
184 Posts
spare tire cover

Started my tire carrier resto. Got everything torn down, sanded, primed and painted. Gotta order some bushings for the mounts now and try to bring the old tire cover back to life. It’s pretty weather beaten, but should be able to get some more life out of it.


Bonus shop dog
Youngdump, here is a spare tire cover "MADE IN THE USA" if you can believe that, it's held up really well fits good, and looks like the original!!
Got it off Amazon, for like $50.00
 

Attachments

·
House of Windsor 4ever!
Joined
·
10,443 Posts
Realized that I installed my GT40 heads backwards, with the open thermactor ports facing the front...
Don't feel bad. I did that on a '77 Mustang II with 302. It was embarrassing, to say the least,:duh to hear exhaust coming from under the A/C compressor bracket....:doh0715:
 

·
Premium Member
Joined
·
34,512 Posts
Youngdump, here is a spare tire cover "MADE IN THE USA" if you can believe that, it's held up really well fits good, and looks like the original!!
Got it off Amazon, for like $50.00
Looked pretty good, so I dug a bit. Picked one up for my '95 through their eBay store.
Hope it's as good as it sounds. Thanks for the tip. :thumbup
 

·
Premium Member
Joined
·
915 Posts
Completed my A/C system rebuild a few minutes ago. The compressor failed and I got a new one and new components to go with it.

Pulled a vacuum on it last night and let it set over night. I checked it this morning and the vacuum held.

Just got done charging it up with the recommended oil and refrigerant charge. Let it run in the carport for about 30 mins and it never skipped a beat.

Gonna go out tonight and test run it on the road and see what it does.

I am thinking it is all good at this point and I am a happy camper!



.
 

·
Registered
Joined
·
1,538 Posts
Pulled the leaking driver side valve cover on wifeys 85. Cleaned and painted and put on a new felpro rubber steel core.



I’ll do the other side when I feel like removing the top half of the motor - geez

Also gave them both a thorough hosing down underneath to fight the winter salt. Next weekend I spray em both down with fluidfilm.

I’ve also been doing a bunch of research on raptor liner. I think I’m going to remove all my XLT moulding, weld the holes, and raptor it gun metal grey or tan like the 85. That’ll keep me out of trouble for a bit.

Cheers


Sent from my iPhone using Tapatalk Pro
 

·
Man of endless projects
Joined
·
8,749 Posts
but did you get the upper? and the injectors? might as well get the cylinder heads also


used the winch on the 96 to pull out 5 palm trees and pull them into a dump trailer
 
17361 - 17380 of 18418 Posts
Top