Bronco Forum - Full Size Ford Bronco Forum banner
1721 - 1740 of 24001 Posts

· Premium Member
Joined
·
4,784 Posts
finished connecting my exhaust system.
 

· Registered
Joined
·
632 Posts
Bought some sliding rear windows for the cap. I'll need to refurbish them, and hopefully install them next year when I paint the top and re-tint all of the windows.

I also bought new upper/lower/bypass radiator hoses, T-stat and gasket for my upcoming radiator replacement. I'll probably do a water pump at the same time.
 

· Super Moderator
Joined
·
7,379 Posts
I tinted the front windows of my DD Brutus. Purchased some Black Magic diy window tint from Wally World and threw it on. Looks pretty good.
before

after 35%


I also got my sliders finished up. Primered, Rustoleum Bed coating and Roll on then 3 coats of Duplicolor metalflake textured paint.
Passenger side

Driverside
 

· Registered
Joined
·
2,521 Posts
Did a radiator flush and fill. And while I was at it replaced my thermostat (my housing had a leak) and water pump by-pass hose. No leaking (so far!) and great heat!!:rockon
 

· Super Moderator
Joined
·
33,867 Posts
yo,
Sprayed pure silicone on door and tg weatherstrips to avoid freezing to metal door and glass in freezing temps
test the silicone on a regular styrofoam cup first; if the cup gets funky or melts, then the can or tube contans oil,,, a regular occurrence now, esp if from China.
 

· Registered
Joined
·
215 Posts
Had to move the Bronco to make way of socal edison replacing the pole in my back yard. but dead battery had to pull the battery from my 500 still didnt start then I use my focus to help jumpstart it. drove around the block and parked the bronco on the side driveway. edison told me yesterday they would be there by 9am still haven't showed up
 

· Premium Member
1991Bronco 5.8L, w/95frontclip, 6"Superlift/SuperRunner, Deaver J40 springs, 35x12.5 K&N, 3"Bassani
Joined
·
827 Posts
Tube Bumpers

Installed my new tube bumpers.
 

Attachments

· Premium Member
Joined
·
627 Posts
found my powersteering pump leaking at the housing...
 

· Registered
Joined
·
463 Posts
Replaced the missing license plate lights, did a little soldering and wiring this afternoon. That's the last of the missing lights anywhere on the rig minus the under hood light which I plan to replace with something different. Everything works like factory.....
But wait, now that everything is back up and running, I noticed a bulb out on the left portion of the gauge cluster LMAO.
 
1721 - 1740 of 24001 Posts
Top