Bronco Forum - Full Size Ford Bronco Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
217 Posts
Discussion Starter #1
i had to drill this out because i needed to get the spindle off, and the bolt holding this on was a tiny 12-point, about 5 mm, and i didnt have a socket for it and couldnt get a wrench in to it. i only drilled it out cuz the one on the other side was missing for who knows how long, looks like a PO drilled that one out. so do i need to get this back on or can i leave it off like the other side is? oh and its a 95, so its got 4wabs, i think it has something to do with it
 

·
Registered
Joined
·
9,894 Posts
I have never seen that before and I've stripped a lot of broncos.. (granted they were older) It has to be for the 4wabs...

You don't need it... Not sure if there will be a light on in the dash saying there's an issue or not...
 

·
Registered
Joined
·
217 Posts
Discussion Starter #3
alright cool. my abs pump doesnt work anyway and i dont plan on replacing it anytime soon, so i guess it all works out
 

·
Registered
Joined
·
474 Posts
I'm pretty sure it's a speed sensor for your front ABS. Any electrical connector associated with it? It might have been disconnected long ago.
 

·
Registered
Joined
·
217 Posts
Discussion Starter #5
well its just a piece of metal, but it covers that rod thing you see in the middle, and that rod thing has a abs connector on the back side of it. it didnt throw any codes with the other side missing it
 

·
Registered
Joined
·
217 Posts
Discussion Starter #6
so anyway, while searching for how to get my seized spindle off, i found out its a sensor gaurd. at least thats what someone else calls it
 
1 - 6 of 6 Posts
Top