Bronco Forum - Full Size Ford Bronco Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
481 Posts
Discussion Starter #1
My truck will turn over but not start. I just went and checked the rail valve and no gas came out. Weird thing is, it wouldnt start the other day so i got ready to call my mechanic the next day. When i went out to it the next morning, turned the key and it cranked. I drove 120 miles that night to chatt where i go to school and it's sat since then, this was like a week ago. Went out to start it today and nothing. Is the fuel pump the only possible problem? Oh yea, 1995 5.8
 

·
Registered
Joined
·
481 Posts
Discussion Starter #3
cant you hear it from inside the cab?
 

·
Registered
Joined
·
481 Posts
Discussion Starter #5
no sound at all except for a click which sounds like a solenoid telling it to turn on or something
 

·
Registered
Joined
·
481 Posts
Discussion Starter #7
nope, in the tank. you think there's a chance the filter could be clogging the line?
 

·
Charlie don't surf..
'92 Ford Bronco XLT
Joined
·
15,066 Posts
Regardless of anything else, you should still hear the pump prime when you turn the key. If you're hearing nothing but the click, you might want to check the pump relay.
 

·
Registered
Joined
·
481 Posts
Discussion Starter #10
where's that at?
 

·
Registered
Joined
·
481 Posts
Discussion Starter #11
TTT still dont know where fuel pump relay is
 

·
Registered
Joined
·
202 Posts
Drivers side on the firewall, I believe its the green one. From what ive been told on here they are notorious for going bad and they should be replaced with Bosch relays.
 

·
Registered
Joined
·
481 Posts
Discussion Starter #13
would that cause the pump not to turn on if the relay was bad?
 

·
Registered
Joined
·
42 Posts
Absolutely.... a relay is a electrically actuated switch.... if the relay goes bad, there will be no voltage going back to your fuel pump. No fuel pump means no pressure.... means no start....
 

·
Registered
Joined
·
481 Posts
Discussion Starter #16
is it in the cab side or engine side of the firewall
 

·
Registered
Joined
·
202 Posts
Shouldve said fenderwall instead of firewall, drivers side. Youll see three of them, well at least thats what I have in my 91. If you do a search on here youll find what pins to jump out to test it also.
 

·
Registered
Joined
·
481 Posts
Discussion Starter #19
so theres a little thin rectangular box on the driver's side wheel well that has relay 1-4 written on it. gotta be it, so i popped the lid off and there was one thin grey plug and three black cubical plugs. i unplugged them all and looked for corrosion or something, it was all good, still didnt start. am i looking in the right spot? Also, could a clogged fuel filter cause the pump to not turn on?
 

·
Registered
Joined
·
3,758 Posts
RedClayBronc said:
so theres a little thin rectangular box on the driver's side wheel well that has relay 1-4 written on it. gotta be it, so i popped the lid off and there was one thin grey plug and three black cubical plugs. i unplugged them all and looked for corrosion or something, it was all good, still didnt start. am i looking in the right spot? Also, could a clogged fuel filter cause the pump to not turn on?
no a clogged filter wont keep the pump from running.
 
1 - 20 of 21 Posts
Top