Bronco Forum - Full Size Ford Bronco Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter #1
Until today my wipers didnt work (just bought the Bronco). I assumed it was the motor and not the switch so I swapped it out. Now when I go to start the truck the wipers cycle once and park themselves at the normal spot at the bottom of the windshield. The motor doesnt sound so good, I'm just glad they are working. Anyone ever seen this before or is this just normal? weird to me.
 

·
Registered
Joined
·
710 Posts
sounds like the switch... I don't like telling people to just throw parts at a problem, but that's what I would place my bets on. you might be able to take it out and clean it... WD40 is meant for cleaning electronics. Pull it out, hose it with WD, then blow it out with compressed air real well. Maybe work it back and forth a little while your hosing it with the WD.

Unless the 91 has the multi-function switch like mine does... In that case I don't think theres any cleaning to it, just have to replace them critters.

If yours takes the Multi-function switch and it's the same as a 94 model, I'll send you my old one for free (if I can find it) the delay wiper function doesn't work on it, but other than that it was fine when i removed it. I pulled it because I thought the headlight part of the switch was bad, turns out my battery was sitting on top of my headlight wire and had worn a spot in it... every time I hit a turn just right I would lose my headlights:rockon that was fun as hell!!!
 

·
Registered
Joined
·
710 Posts
nope, just checked rock auto and yours is not the multi-switch. I'd try cleaning it, then replacing it (it's only 20 bucks). Sounds like something is making contact in there and whenever it gets the first "jolt" from starting the truck it's thinking you turned it on.
 

·
Registered
Joined
·
103 Posts
Discussion Starter #4
Ok, so next time I will wait longer than an hour to post something I have a question about; I figured out part of it. Turned ccw it goes to intermittent wipers, turn to first detent clockwise, off, second, slow, third fast.

I will have to try the motor while at speed with rain but with the engine off it does sound louder than I think it should be.
 
1 - 4 of 4 Posts
Top