Bronco Forum - Full Size Ford Bronco Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
671 Posts
Discussion Starter #1
My bronco's trans has had problems for 30K now with OD not working, and heat issues. I have deveoloped new problems, so I need to get off my ass and get a transmission. I would prefer one that is a pre '94 with updates installed, with a torque converter. whatcha got?
 

·
Registered
Joined
·
621 Posts
pre 94 updates weren't installed im pretty sure 95 96 and expeditions had updates. mine is from a 97 expedition but needed electrical adapters.
 

·
Registered
Joined
·
671 Posts
Discussion Starter #3
you can have them rebuilt and have the updates installed. That is what I am looking for, not a stock unit with 100k+ on it. I useless search I know :(
 

·
Registered
Joined
·
671 Posts
Discussion Starter #7
I did have it diagnosed. They belive the front pump is warped and leaking internally(the reason why it wouldn hold OD) The trans finally figured out something is wrong and now is in a partial limp home mode where the computer has bumped up the line pressure to max, it holds OD now, but it bangs gears. THe guy believes that by now I have hard part damage, its been screwed up for about 30K now.
 

·
FSB Pimpster & Recruiter
Joined
·
5,716 Posts
Defenitely sounds like a front pump issue....Also, you might have some problems with your Valve Body....

As mentioned by Ian, Almost every E4OD needs an update.....

As for your OH problem it might be a bad Torque converter....Which should be replaced at time of rebuilt....

Good luck,
Allcruisen :imp :usa
 

·
Registered
Joined
·
671 Posts
Discussion Starter #9
the torque converter I suspect is another problem. FOr a while I was getting E4OD death shimmies over 3000RPM in 3rd gear. It went away, but I know the TQ needs to go as well.

TTT
 
1 - 9 of 9 Posts
Top